HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Error 500 accessing ISPConfig admin interface (http://www.howtoforge.com/forums/showthread.php?t=62280)

razor7 19th June 2013 17:31

[Solved] Error 500 accessing ISPConfig admin interface
 
Hi, I have recently upgraded to ISPConfig 3.0.5.2 using upgrade shell script. When trying to access ISPConfig admin interface, I get Error 500.

The access URL is https://serverdomain.com:8080/

I'm using full upgraded Ubuntu 12.04.2 LTS and ISPConfig 3.0.5.2

This is the excerpt of apache error.log
Quote:

[Wed Jun 19 12:14:27 2013] [notice] caught SIGTERM, shutting down
[Wed Jun 19 12:14:28 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Jun 19 12:14:28 2013] [notice] Digest: generating secret for digest authentication ...
[Wed Jun 19 12:14:28 2013] [notice] Digest: done
[Wed Jun 19 12:14:28 2013] [notice] FastCGI: process manager initialized (pid 6651)
[Wed Jun 19 12:14:28 2013] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 Phusion_Passenger/3.0.21 PHP/5.3.10-1ubuntu3.6 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.22 OpenSSL/1.0.1 configured -- resuming normal operations
suexec policy violation: see suexec log for more details
[Wed Jun 19 12:14:31 2013] [warn] [client 10.0.0.2] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Wed Jun 19 12:14:31 2013] [error] [client 10.0.0.2] Premature end of script headers: index.php
Excerpt of suexec.log
Quote:

[2013-06-19 12:14:31]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
[2013-06-19 12:14:31]: target uid/gid (5003/5004) mismatch with directory (0/0) or program (0/0)
I have been using ISPConfig without any errors since 8 months, but now, this issue pops up.

Please advise

Thanks a lot!

razor7 19th June 2013 18:00

Got it working again, just in case anyone gets this kind of error in suexec.log, I leave the exact command that got it working.

Quote:

# chown ispconfig:ispconfig /var/www/php-fcgi-scripts/ispconfig/ -R


All times are GMT +2. The time now is 14:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.