HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Cron problems (http://www.howtoforge.com/forums/showthread.php?t=62253)

sjau 17th June 2013 07:32

Cron problems
 
Hi there

I setup a few cronjob, e.g.:

one is like that:

Code:

/var/www/clients/client1/web9/web/urteile/cron.sh
and the resulting file in /etc/cron.d looks like this:
Code:

cat ispc_chrooted_web9                                                                                                                                                                                                                             
MAILTO=''                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                             
#SHELL='/usr/sbin/jk_chrootsh'                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                             
10      12,13  *      *      *      web9    /var/www/clients/client1/web9/web/urteile/cron.sh      #regenmacher.ch


However a new one I created looks like this:
Code:

/var/www/clients/client1/web41/web/sr_orig/cron.sh  2>&1 | mail -s "SR Cron" 'user@domain.com'
but the entry in cron.d looks like that:
Code:

cat ispc_chrooted_web41
MAILTO=''                                                                                                                                                                                                                                                                     
SHELL='/usr/sbin/jk_chrootsh'                                                                                                                                                                                                                                                 
                                                                                                                                                                                                                                                                             
30      7      *      *      *      web41  /web/sr_orig/cron.sh  2>&1 | mail -s "SR Cron" 'user@domain.com' #sub.domain.com

For some reason the web41 is chrooted but I don't recall having set chrooting up for it.

sjau 17th June 2013 08:11

fixed it :)


All times are GMT +2. The time now is 03:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.