HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   ISPConfig 3 Priority Support (http://www.howtoforge.com/forums/forumdisplay.php?f=35)
-   -   Horde 5.1 and ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=62185)

sjswarts 11th June 2013 18:39

Horde 5.1 and ISPConfig 3
 
G'day guys,

Been using ISPConfig for quite awhile now and its very good - stable, well maintained, free, well you get my drift.

One thing however has bugged me since I've started using Horde as a Groupware. That I cannot get the Tasks to work properly.

I've previously asked for help here:

http://www.howtoforge.com/forums/showthread.php?t=59847

I've also asked for help on the Horde mailing list, but I hit a wall:

http://pastebin.com/e8h2ZHT9

Any other logs, or what not please do not hesitate to PM or put it back here... I'm positive that I'm not the only one who has ISPConfig 3 and Horde running.

till 11th June 2013 18:57

ISPConfig applies strict settings to every directory in /var/www that s not a website, so it might be that some of your horde settings dos not get applied or that they got negated or overridden.

Try to move the apache horde config file to /etc/apache2/sites-available/, then create a symlink in /etc/apache2/sites-enabled/ to that file, the name of the symlink should be at after the sites in alhabetical order e.g. 999-horde.conf and restart apache.

This ensures that the horde config file is loaded in apache after the ispconfig.conf and ispconfig.vhost file

sjswarts 11th June 2013 19:10

Thanks for the response Till, but no joy...

I moved it to
Code:

/etc/apache2/sites-available/horde.conf
Created a symlink

Code:

ln -s /etc/apache2/sites-available/horde.conf /etc/apache2/sites-enabled/999-horde.conf
Code:

/etc/init.d/apache2 restart
Same errors, no difference

sjswarts 14th June 2013 08:29

Ok this is driving me nuts, also I paid for 6 months of priority support. I realize that its well and truly in the hard basket but I need this to be fixed.

New task creation redirects the browser to this:

https://www.swartsit.com/horde/nag/t/save

P.S.

I have tried talking with Horde, they handball it to you guys.
I have tried talking with Apache support and they just feed me mod_rewrite docs.

Is there no one who teaches by demonstration anymore? Man I hate reading, learning by trial and error is the way I do exactly that - Learn

/rant

till 14th June 2013 08:57

The horde config looks normal that you posted and it should work. Maybe you have some rewrite rules in the website www.swartsit.com which interferes with horde.

sjswarts 14th June 2013 10:03

Yeah that is possible.

This is what my /etc/apache2/conf.d has in it:

Code:

root@mail:/etc/apache2/conf.d# ll
total 28
drwxr-xr-x 2 root root 4096 Jun 12 00:59 .
drwxr-xr-x 7 root root 4096 Mar  5 09:39 ..
-rw-r--r-- 1 root root  237 Sep 10  2012 apache2-doc
-rw-r--r-- 1 root root  269 Sep 13  2012 charset
lrwxrwxrwx 1 root root  45 Oct 19  2012 javascript-common.conf -> /etc/javascript-common/javascript-common.conf
-rw-r--r-- 1 root root 3296 Sep 13  2012 localized-error-pages
lrwxrwxrwx 1 root root  23 Nov 29  2012 munin -> ../../munin/apache.conf
-rw-r--r-- 1 root root  143 Sep 13  2012 other-vhosts-access-log
lrwxrwxrwx 1 root root  28 Oct 20  2012 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
-rw-r--r-- 1 root root 1424 Sep 13  2012 security

I think the only ones I've changed are:

phpmyadmin.conf - http://pastebin.com/UWn6bVdF

munin -http://pastebin.com/Gf268Z6L

Otherwise I have these settings in my ISPConfig panel under website swartsit.com

http://www.swartsit.com/blog/?attachment_id=188

vhost is - http://pastebin.com/X7vWji2m

till 14th June 2013 10:09

Please remove the horde related rewrite rules that you added in ispconfig, e.g. this one:

RewriteCond %{HTTP_HOST} ^webmail\.example\.com$ [NC]
RewriteRule ^/(.*)$ https://www.example.com/horde/$1 [R]

as they interfere with the horde setup you made. and there might be more conflicting rewrite rules in a .htaccess file in the website.

Please try to use horde trough the IP address and additionally trough another site of this server to se if this has any influence.

sjswarts 14th June 2013 10:13

OK I will try that,

Do I need to enable Python or any other type of programming language?

till 14th June 2013 10:16

Quote:

Do I need to enable Python or any other type of programming language?
Not as far as I know. But I'am not a horde developer so I dont know their code nor software requirements in detail.

sjswarts 14th June 2013 10:18

Ok I tried that no luck, different website that I host. Still this error.

[14/Jun/2013:16:14:58 +0800] "POST /horde/nag/t/save HTTP/1.1" 404 809 "https://cleandrum.com/horde/nag/task.php?actionID=add_task" "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0"

File does not exist: /var/www/horde/nag/t, referer: https://cleandrum.com/horde/nag/task...ionID=add_task


All times are GMT +2. The time now is 11:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.