HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Weird issue with dns (http://www.howtoforge.com/forums/showthread.php?t=62096)

jonathand 5th June 2013 17:23

Weird issue with dns
 
Hello,

I'm running the bind service for resolving internal dns names here in our office. It's been working fine for the last year then all of a sudden maps.google.com stopped resolving and started to resolve internally instead.

Here is the output of the dig from my local machine:

Code:

[root@jonathan cron]# dig @192.168.15.10 maps.google.com
;; Truncated, retrying in TCP mode.
;; Connection to 192.168.15.10#53(192.168.15.10) for maps.google.com failed: host unreachable.

And here is the output directly from the server running BIND.

Code:

[root@dns named]# dig @192.168.15.10 maps.google.com
;; Truncated, retrying in TCP mode.

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> @192.168.15.10 maps.google.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17493
;; flags: qr rd ra; QUERY: 1, ANSWER: 17, AUTHORITY: 13, ADDITIONAL: 0

;; QUESTION SECTION:
;maps.google.com.                IN        A

;; ANSWER SECTION:
maps.google.com.        21287        IN        CNAME        maps.l.google.com.
maps.l.google.com.        255        IN        A        66.185.95.24
maps.l.google.com.        255        IN        A        66.185.95.50
maps.l.google.com.        255        IN        A        66.185.95.35
maps.l.google.com.        255        IN        A        66.185.95.30
maps.l.google.com.        255        IN        A        66.185.95.59
maps.l.google.com.        255        IN        A        66.185.95.40
maps.l.google.com.        255        IN        A        66.185.95.54
maps.l.google.com.        255        IN        A        66.185.95.20
maps.l.google.com.        255        IN        A        66.185.95.44
maps.l.google.com.        255        IN        A        66.185.95.39
maps.l.google.com.        255        IN        A        66.185.95.34
maps.l.google.com.        255        IN        A        66.185.95.29
maps.l.google.com.        255        IN        A        66.185.95.45
maps.l.google.com.        255        IN        A        66.185.95.25
maps.l.google.com.        255        IN        A        66.185.95.55
maps.l.google.com.        255        IN        A        66.185.95.49

;; AUTHORITY SECTION:
.                        15364        IN        NS        a.root-servers.net.
.                        15364        IN        NS        h.root-servers.net.
.                        15364        IN        NS        f.root-servers.net.
.                        15364        IN        NS        i.root-servers.net.
.                        15364        IN        NS        d.root-servers.net.
.                        15364        IN        NS        g.root-servers.net.
.                        15364        IN        NS        b.root-servers.net.
.                        15364        IN        NS        l.root-servers.net.
.                        15364        IN        NS        m.root-servers.net.
.                        15364        IN        NS        c.root-servers.net.
.                        15364        IN        NS        e.root-servers.net.
.                        15364        IN        NS        j.root-servers.net.
.                        15364        IN        NS        k.root-servers.net.

;; Query time: 0 msec
;; SERVER: 192.168.15.10#53(192.168.15.10)
;; WHEN: Wed Jun  5 11:06:49 2013
;; MSG SIZE  rcvd: 521

Here is my named.conf file (minus our included zones)

Code:

options {
        listen-on port 53 {
                192.168.15.10;
                192.168.15.11;
                192.168.15.12;
                127.0.0.1;
        };
        directory        "/var/named";
        dump-file        "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
        allow-query-cache {
                192.168.15.0/24;
                127.0.0.1;
        };
        allow-recursion {
                192.168.15.0/24;
                127.0.0.1;
        };
        allow-query {
                192.168.15.0/24;
                127.0.0.1;
        };
        forwarders {
                8.8.8.8;
                8.8.4.4;
        };

        /* Path to ISC DLV key */
        bindkeys-file "/etc/named.iscdlv.key";
};


mzandstra 10th June 2013 00:29

Is it possible the IP of the client machine isn't within the allow-query range?

jonathand 10th June 2013 15:37

Nope not a possibility at all, as I can query every other address thus far.

I ended up changing the forwarding addresses to something else instead, and that seems to have fixed the issue, however it's still disconcerting that it wasn't working with google's public dns servers.


All times are GMT +2. The time now is 02:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.