HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Mail Problem (http://www.howtoforge.com/forums/showthread.php?t=62094)

ifuXz 5th June 2013 15:58

Mail Problem
 
Hello,

i a problem with the mail server. When i send a mail to google mail all is fine. When i send a mail to another mail (on a other server from me) i see no mail in the inbox.

All mails on this mail-adress are hanging in the queue. What can be the problem?

In the log are no error only the message:
Jun 5 09:39:31 host postfix/qmgr[3558]: 01B9D3A63F0: from=<root@host>, size=1490, nrcpt=1 (queue active)

monkfish 5th June 2013 18:15

Hello ifuXz

Do you have access to the server you are trying to send mail to? If so, are there any entries in the mail log on that server?

Also, on the sending server, try a "postqueue -p".

This will list your messages that are queued and will probably give you any reason as to why its queued and not been processed.

HTH

ifuXz 5th June 2013 18:26

I monkfish,

i have access to both servers.

The error is: -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
C98DD6E0605 62730 Sun Jun 2 22:44:07 xx@host.de
(connect to mail.xy.de[8x.xx.xx.xx]:25: No route to host)
bill@xy.de

monkfish 5th June 2013 18:35

Quote:

(connect to mail.xy.de[8x.xx.xx.xx]:25: No route to host)
Things to check;

- is a mail daemon running on the destination machine
- is it set to listen on the correct ip address and correct tcp port (do a "netstat -nlp" to check)
- if necessary restart the mail server on receiving machine - any errors in the log?
- is your networking config good (probably is, as you said you can send email to gmail)
- perhaps watch both mail logs (use "tail -f /var/log/maillog" or similar) and try a "postqueue -f" on the sending server to see if you can flush the queue. Look for any errors to show you why its not being delivered.

HTH

ifuXz 5th June 2013 18:40

Things to check;

- is a mail daemon running on the destination machine

Yes
- is it set to listen on the correct ip address and correct tcp port

Yes

- if necessary restart the mail server on receiving machine - any errors in the log?
Error no only that the mail is in the queue

status=deferred (connect to mail.xx.de[8x.xx.xx.xx]:25: No route to host) - 1 example

- is your networking config good (probably is, as you said you can send email to gmail)

I think it is all right because a mail to gmail is send without problem


//Edit:
it can be the rdns/ptr dns record i think but this one is already set

ifuXz 6th June 2013 15:55

It was a bug in the switch configuration which blocks internal traffic


All times are GMT +2. The time now is 13:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.