HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   mail_user_add not working (http://www.howtoforge.com/forums/showthread.php?t=61965)

realtebo 25th May 2013 12:14

mail_user_add not working
 
I'd like to share with you this piece of my log file.

I'm doing something wrong with mail_user_add function. Because it give me 3 errors



Code:

2013/05/25 11:08:54 [trace] [ispconfigsoap] updateMailConfig - Cliente #62: gatto.pardo@libero.it - alepado
2013/05/25 11:08:55 [trace] [ispconfigsoap] Logged successfull. Session ID:a10efcc3f995bc89068db6b5687ea451
2013/05/25 11:08:55 [trace] [ispconfigsoap] array
(
    'server_id' => 1
    'email' => 'gatto.pardo-libero.it@smsdevmirko.ispeed.local'
    'login' => 'gatto.pardo-libero.it@smsdevmirko.ispeed.local'
    'password' => 'alepado'
    'name' => 'gatto pardo (test59)'
    'uid' => 5000
    'gid' => 5000
    'maildir' => '/data/var/vmail/smsdevmirko.ispeed.local/gatto.pardo-libero.it'
    'quota' => 0
    'cc' => ''
    'homedir' => '/data/var/vmail'
    'autoresponder' => 'n'
    'autoresponder_start_date' => ''
    'autoresponder_end_date' => ''
    'autoresponder_text' => ''
    'move_junk' => 'y'
    'custom_mailfilter' => ''
    'access' => 'n'
    'disabledeliver' => 'n'
    'disablesmtp' => 'n'
    'postfix' => 'y'
    'disableimap' => 'y'
    'disablepop3' => 'y'
)
2013/05/25 11:08:55 [trace] [ispconfigsoap] Exception in updateMailConfig per gatto.pardo@libero.it:
quota_size_error_empty<br />
quota_size_error_regex<br />
directory_error_empty<br />

I know it's strange to create mailbox with this kind of username, but it's necessary for our internal needs, and please keep in mind that when I tried to modify mail_user_add.php into examples dir of installation file and run it with php -f mail_user_add.php using the same parameters everything worked

Code:

root@vldidevhost1:~/ispconfig3_install/remoting_client/examples# php -f mail_user_add.php

Logged successfull. Session ID:0f046f41dba366a39bf6ad79a1458e12
New user: 13
Logged out.<br />

The same code, with same parameters created a new user with is 13, but when it run from my code it give me 100% of times the error pasted at the top.

Why ? What could be the problem ? Why the same api with the same parameters do different things ?!


All times are GMT +2. The time now is 11:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.