HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=29)
-   -   ISPConfig + Roundcube - We need a vacation plugin (http://www.howtoforge.com/forums/showthread.php?t=61964)

Steve85 25th May 2013 10:21

ISPConfig + Roundcube - We need a vacation plugin
 
Hello all,

i`m searching for a working plugin for my "Roundcube". I want to give my users the option to manage his "Out of office" replies.

I use ISPConfig and tried two plugins but this don`t looks very well.

http://github.com/bhuisgen/rc-vacation/

and

http://sourceforge.net/projects/rcubevacation/

This don`t works for me.

Did you know a plugin which works for ISPConfig and uses the API as example?

Best,
Steve

Horfic 25th May 2013 10:46

well... you didn't go the easy way.

You will find under the download section on www.ispconfig.org the link to my roundcube plugins.

Which are here: https://github.com/w2c/ispconfig3_roundcube

The account plugin is necessary for all other plugins, other than that you can activate each plugin seperately.

Docu: https://github.com/w2c/ispconfig3_roundcube/wiki/_pages

PS: The plugin you seek is the ispconfig3_autoreply plugin.
PPS: If you experience issues, read first the docu.

Steve85 25th May 2013 11:32

Oh great.

I tried to install but if i add the "roundcube.conf" to my apache2 folder and i want to restart the apache i get this error:

"httpd start: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 59 of /etc/httpd/conf.d/roundcube.conf: Expected </link> but saw </head>"

I dont see line 59? xD Any idea?

Horfic 25th May 2013 11:38

well you don't need the roundcube.conf for the plugins to work, that is only if you want to have /webmail available at your domains.

depends what platform you are on and what webserver you are exactly using.

what are you doing in httpd.conf in line 221

Steve85 25th May 2013 11:42

Ok - i try to get it active (actual working on https) ;-)

The line loads your config:

# Load config files from the config directory "/etc/httpd/conf.d".
#
Include conf.d/*.conf

Horfic 25th May 2013 11:46

you are loading from

/etc/httpd/conf.d/httpd.conf

this

/etc/httpd/conf.d/*.conf


isn't this getting you a loop?

Steve85 25th May 2013 11:48

Im loading from:
/etc/httpd/conf/httpd.conf

Confd is located:
/etc/httpd/conf.d

Steve85 25th May 2013 11:57

If i access over http it is all fine but i get this error:"Soap Error: fetching http headers"

So i try to get it working over https but if i access the website over https (https://my-domain.com:8081/roundcube)

I get forwarded to "https://my-domain.com/roundcube" and there comes the error "Site not found".

Maybe i need the "roundcube.conf" that it works well?

Any idea?

Horfic 25th May 2013 12:01

you didn't read the docs...

https://github.com/w2c/ispconfig3_ro...shooting---FAQ

Q: I get an error "Soap Error: fetching http headers"
A: This happens when the plugins are trying to reach your interface under http but you have it run it under https. So just change it in the config file.

PS: Roundcube conf simply adds the alias /webmail to apache...

Steve85 25th May 2013 12:03

Hm of course...

I changed the value to:
"$rcmail_config['force_https'] = true;"

I get now the error in my browser = "ssl_error_rx_record_too_long".

I use a self signed certificate? Maybe is this a problem?


All times are GMT +2. The time now is 18:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.