HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPconfig 3 mail loops back to me (http://www.howtoforge.com/forums/showthread.php?t=61939)

sixone 23rd May 2013 15:13

ISPconfig 3 mail loops back to myself
 
Hi

I installed ISPconfig 3 with Courier IMAP/POP3 and maildrop a while ago. Everything was fine, until i noticed that mail filters (like filtering junk or autoresponder) is not working because relay was 'virtual' not 'maildrop'.
I changed it to 'maildrop', filtering is working, but aliases or forwarding are not working anymore.
Now maildrop / postfix is not checking virtual aliases in mysql, it says something with permission denied, user does not exists, which is kinda true, cause there's no file/folder in /var/vmail for that user, it's an alias in mysql forward table.

So, my dilemma is how can i get both of them working, aliases and maildrop filtering?

right now i have this config:
..
virtual_transport = maildrop
best_mx_transport = virtual
..
changes were made to best_mx_transport from virtual to maildrop
if i comment out the best_mx_tranport or delete it, i get an error, mail looks back to myself.
domain to which i'm trying to send email and get the error does exists in domain table, it's working if i set it to virtual or maildrop.

hope that makes sens :)

sixone 12th June 2013 11:50

i still didn't figure out what's happening, any help would be appreciated :)

till 12th June 2013 12:10

download the ispconfig tar.gz file again, unpack it and run the update.php script which is in the install folder. Choose to reconfigure services during update.


All times are GMT +2. The time now is 03:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.