HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Wordpress 3.5.1 "client intended to send too large body" (http://www.howtoforge.com/forums/showthread.php?t=61904)

mhpcomputerservices 20th May 2013 18:42

Wordpress 3.5.1 "client intended to send too large body"
 
I've migrated a Wordpress 5.3.1 site ....

-from-

Debian 6.0
Ispconfig 3.0.5.2
Apache 2.2.16
php 5.3.24 (fast-cgi)

-to-

Ubuntu 12.0.4.2LTS
Ispconfig 3.0.5.2
Nginx 1.4.1
php 5.3.10 (php-fpm)

All was working fine on the original server. However, on the new server when attempting to upload an image we see a wordpress 'HTTP error'.

Examining the Nginx logs shows:-
Code:

2013/05/20 17:04:25 [error] 5219#0: *84543 client intended to send too large body: 1438769 bytes, client: *EDITED*, server: *EDITED*.co.uk, request: "POST /wp-admin/async-upload.php HTTP/1.1", host: "www.*EDITED*.co.uk", referrer: "http://www.*EDITED*.co.uk/wp-admin/media-new.php"
This is driving me nuts! I've changed client_max_body_size to 200M and it has no effect :confused:

Code:

root@i7:/etc/nginx# grep -R 'client_max_body_size' *
nginx.conf:        client_max_body_size 200M;
sites-available/apps.vhost:        client_max_body_size 200M;
sites-available/ispconfig.vhost:        client_max_body_size 200M;
sites-enabled/000-ispconfig.vhost:        client_max_body_size 200M;
sites-enabled/000-apps.vhost:        client_max_body_size 200M;

php.ini has also been altered to suit:
Code:

upload_max_filesize = 200M
Code:

post_max_size = 200M
Ispconfig Nginx Directives
Code:

location = /favicon.ico {
                log_not_found off;
                access_log off;
        }
 
        location = /robots.txt {
                allow all;
                log_not_found off;
                access_log off;
        }
 
        location / {
                # This is cool because no php is touched for static content.
                # include the "?$args" part so non-default permalinks doesn't break when using query string
                try_files $uri $uri/ /index.php?$args;
        }
 
        location ~ \.php$ {
                #NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
                include fastcgi.conf;
                fastcgi_intercept_errors on;
                fastcgi_pass php;
        }
 
        location ~* \.(js|css|png|jpg|jpeg|gif|ico)$ {
                expires max;
                log_not_found off;
        }

Ispconfig Custom php.ini settings
Code:

cgi.fix_pathinfo = 0;
Can anyone offer any advise here?

Thanks

mhpcomputerservices 21st May 2013 11:36

Anyone? :(

jaypabs 23rd June 2013 06:22

I'm having the same problem also. Did you fix yours?

I'm also using php5-fpm, nginx.

falko 24th June 2013 17:51

Can you add

Code:

client_max_body_size to 200M;
to the nginx Directives field?


All times are GMT +2. The time now is 06:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.