HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Plugins/Modules/Addons (http://www.howtoforge.com/forums/forumdisplay.php?f=34)
-   -   Roundcube invalid sever name (http://www.howtoforge.com/forums/showthread.php?t=61877)

chief 18th May 2013 03:03

Roundcube invalid sever name
 
Hi,

I have run an upgrade on ispconfig 3 to version 3.0.5.2 which seemed to run perfectly fine.
But i have found a problem with roundcubemail.

before i upgraded it was verion .03 (i think) - well it worked fine before upgrade

I usually login via www.mywebsite.com/roundcube

after upgrade i could not log in, it had a login screen, when i typed email address and a password screen went to a white screen, and nothing.

i renamed /var/www/apps/roundcube to roundcube.old

went to system - packages and deleted roundcube.
then refreshed panel to reinstall roundcube again.
it seemed to reinstall fine, ssh in to check folder and new one was created.
under monitor - server had an error message
"Unable to connect to the databaseCan't create database 'ispapp1'; database exists"
I logged into phpmyadmin and renamed database, opened ssh terminal to server and ran "service httpd restart" went back in to phpmyadmin and it had created new database.

Now i have a new fresh looking login screen, but still cannnot login.
It now states "Invali server name"

chief 18th May 2013 03:44

Quote:

Originally Posted by chief (Post 297396)
Hi,

I have run an upgrade on ispconfig 3 to version 3.0.5.2 which seemed to run perfectly fine.
But i have found a problem with roundcubemail.

before i upgraded it was verion .03 (i think) - well it worked fine before upgrade

after upgrade i could not log in, it had a login screen, when i typed email address and a password screen went to a white screen, and nothing.

i renamed /var/www/apps/roundcube to roundcube.old

went to system - packages and deleted roundcube.
then refreshed panel to reinstall roundcube again.
it seemed to reinstall fine, ssh in to check folder and new one was created.
under monitor - server had an error message
"Unable to connect to the databaseCan't create database 'ispapp1'; database exists"
I logged into phpmyadmin and renamed database, opened ssh terminal to server and ran "service httpd restart" went back in to phpmyadmin and it had created new database.

Now i have a new fresh looking login screen, but still cannnot login.
It now states "Invali server name"

BUT when i go www.mywebsite.com/webmail i can login, so my problem is with roundcubemail

help please, thanks in advance

chief 18th May 2013 04:39

Sussed it...

edit /var/www/apps/roundcube/config/main.inc.php
line 75
Code:

$rcmail_config['default_host'] = '$s";
and change $s to localhost - $s works via domain name

and hey presto i can log in


dave


All times are GMT +2. The time now is 18:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.