HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   SSL Not working right (http://www.howtoforge.com/forums/showthread.php?t=61857)

pebkac 16th May 2013 16:29

SSL Not working right
 
Steps I took:

Enabled SSL and chose an IP for the site.
On SSL tab selected create SSL
Took that request and entered it in startssl
The gave me a cert, which I entered into the SSL tab and then chose save certs.

Tried the site, and got an error about SSL being too long. I changed the ip to the * and saved it and now the sites comes up but I get an SSL warning about the cert not being ok, i can proceed through though.

What am I doing wrong? I need this to work.

Update: Here is the error I get in Chrome with the IP specified.
Quote:

Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.
Here is what it looks like when I restart Apache:
Quote:

root@dor:~# /etc/init.d/apache2 restart
* Restarting web server apache2 [Thu May 16 14:53:10 2013] [warn] NameVirtualHost 184.169.151.252:80 has no VirtualHosts
[Thu May 16 14:53:10 2013] [warn] NameVirtualHost 184.169.151.252:443 has no VirtualHosts
... waiting [Thu May 16 14:53:11 2013] [warn] NameVirtualHost 184.169.151.252:80 has no VirtualHosts
[Thu May 16 14:53:11 2013] [warn] NameVirtualHost 184.169.151.252:443 has no VirtualHosts
UPDATE 2: Not sure what happened but it is now working. I switched back from specified IP to * (wildcard) and restarted apache, and got the same above error..but now the site is loading with SSL and now warnings.

I do have another question, how can I force SSL on everyone that goes to the site, meaning even if they just enter my domain without SSL it automatically makes it SSL?

falko 17th May 2013 21:03

Quote:

Originally Posted by pebkac (Post 297316)
Steps I took:

Enabled SSL and chose an IP for the site.
On SSL tab selected create SSL
Took that request and entered it in startssl
The gave me a cert, which I entered into the SSL tab and then chose save certs.

Tried the site, and got an error about SSL being too long. I changed the ip to the * and saved it and now the sites comes up but I get an SSL warning about the cert not being ok, i can proceed through though.

What am I doing wrong? I need this to work.

Update: Here is the error I get in Chrome with the IP specified.


Here is what it looks like when I restart Apache:


UPDATE 2: Not sure what happened but it is now working. I switched back from specified IP to * (wildcard) and restarted apache, and got the same above error..but now the site is loading with SSL and now warnings.

Are there any errors in Apache's error log?

What values did you enter on the SSL tab? Maybe some of them are not valid.

Quote:

]I do have another question, how can I force SSL on everyone that goes to the site, meaning even if they just enter my domain without SSL it automatically makes it SSL?
http://wiki.apache.org/httpd/RewriteHTTPToHTTPS


All times are GMT +2. The time now is 12:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.