HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   stuck in upgrade hell (http://www.howtoforge.com/forums/showthread.php?t=61807)

Ovidiu 11th May 2013 10:45

stuck in upgrade hell
 
Tried to upgrade from Debian squeeze to wheezy and am stuck. Read and tried following a couple of tutorials including the one available here on howtoforge.

Currently getting this:

Quote:

apt-get dist-upgrade -u -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38 is installed
locales : Depends: glibc-2.13-1 but it is not installable
perl-modules : Depends: perl (>= 5.14.2-1) but 5.10.1-17squeeze6 is installed
E: Unmet dependencies. Try using -f.
using apt-get -f install suggests:

0 upgraded, 0 newly installed, 289 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 461 MB disk space will be freed.


So I did not go forward with that.

Any hints? Google only gives me 2 viable results and both have no real solution.

Ovidiu 11th May 2013 11:34

making slowly progress:

- edited my sources list, put it all back to SQUEEZE then tried this:

Quote:

apt-get install libc6/squeeze libc-bin/squeeze perl/squeeze perl-modules/squeeze locales/squeeze -u
result:

Quote:

apt-get dist-upgrade -u
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
THEN using this tutorial: http://www.howtoforge.com/how-to-upg...eeze-to-wheezy

I changes my sources to match WHEEZY then did an apt-get upgrade which resulted in:

Quote:

Errors were encountered while processing:
/var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
did apt-get upgrade again and saw this:

Quote:

Unpacking replacement mysql-client-5.5 ...
dpkg: error processing /var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_i386.deb (--unpack):
trying to overwrite '/usr/bin/mysql', which is also in package mysql-client-core-5.5 5.5.30-1~dotdeb.0
configured to not write apport reports
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
YES, I did use dotdeb at some stage so I removed mysql-client-core-5.5:

Quote:

apt-get remove mysql-client-core-5.5 -u
I followed up with an apt-get dist-upgrade and was told all is well but:

Quote:

The following packages will be REMOVED:
libdigest-sha1-perl php5-gd php5-suhosin
and
Quote:

164 upgraded, 66 newly installed, 3 to remove and 1 not upgraded.
after going through with this, I hit an error which I missed copy/pasting saying something about some libc library needing a 2.6 kernel and I am supposed to add some "LENNY" sources to my sources list but Lenny is way outdated, WTF?

so currently I'm back to this:

Quote:

apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
ifupdown : Depends: initscripts (>= 2.88dsf-25) but 2.88dsf-13.1+squeeze1 is installed
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38 is installed
locales : Depends: glibc-2.13-1
E: Unmet dependencies. Try using -f.
and then I tried this which brings me back to my original libc6 problem so I guess I'll just have ot go all the way back to squeeze !?

Quote:

apt-get install initscripts/wheezy util-linux/wheezy -u
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '2.88dsf-41' (Debian:7.0.0/stable [i386]) for 'initscripts'
Selected version '2.20.1-5.3' (Debian:7.0.0/stable [i386]) for 'util-linux'
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38 is to be installed
locales : Depends: glibc-2.13-1
util-linux : PreDepends: libblkid1 (>= 2.20.1) but 2.17.2-9 is to be installed
PreDepends: libslang2 (>= 2.2.4) but 2.2.2-4 is to be installed
PreDepends: libtinfo5 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ovidiu 11th May 2013 11:50

This didn't give any errors apparently so I started it:

Quote:

apt-get install libc6/wheezy libc-dev-bin/wheezy libc6-dev/wheezy libc6-i686/wheezy gcc-4.4/wheezy gcc-4.4-base/wheezy cpp-4.4/wheezy libgcc1/wheezy libgomp1/wheezy libgmp10/wheezy libmpfr4/wheezy multiarch-support/wheezy initscripts/wheezy libstdc++6/wheezy util-linux/wheezy libblkid1/wheezy libslang2/wheezy libtinfo5/wheezy
BUT it still resulted in one:

Quote:

Preparing to replace libc6 2.11.3-4 (using .../libc6_2.13-38_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.13-38_i386.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.13-38_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
So it looks like I need to upgrade my kernel:
Quote:

uname -r
2.6.18-028stab094.3

Ovidiu 11th May 2013 11:55

Found a possible explanation for this but need confirmation: this server is a small VPS from Server4You and I "think" its a XEN VPS so I cannot upgrade my kernel unless they upgrade the host kernel or am I wrong here? Will contact support and ask.


All times are GMT +2. The time now is 07:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.