HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   pure-ftpd: can't connect (http://www.howtoforge.com/forums/showthread.php?t=61799)

cmsits 10th May 2013 23:52

pure-ftpd: can't connect
 
Its been baffling me for a couple of days. I followed the tutorial
The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3)

and at the bottom of page 4
That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.
But when I tried I got the SSL certificate
but none of the data I put In showed up. I said ok & trusted the cerificate anyway as I know its my server and i'm connecting locally. & then I got

Error: Critical error
Error: Could not connect to server


I used the Encryption: Require explicit FTP over TLS (I'm using FileZilla)

I'm quite new to this, where am I going wrong?

Any help would be truly grateful... Thanks :)

till 12th May 2013 16:24

Seems as if you require tls in your client ithout having ls enabled in the ftp server configuration. Does it work without tls?

Btw. If you are quite new to this, why havent you choosen one of the recommended linux distributions debian or ubuntu? They are much easier to install then centos and even more table on the long run.

Hairy 12th May 2013 16:34

Quote:

Originally Posted by cmsits (Post 296999)
Its been baffling me for a couple of days. I followed the tutorial
The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3)

and at the bottom of page 4
That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.
But when I tried I got the SSL certificate
but none of the data I put In showed up. I said ok & trusted the cerificate anyway as I know its my server and i'm connecting locally. & then I got

Error: Critical error
Error: Could not connect to server


I used the Encryption: Require explicit FTP over TLS (I'm using FileZilla)

I'm quite new to this, where am I going wrong?

Any help would be truly grateful... Thanks :)

Did you configure TLS in pure-ftpd AFTER installing ISPConfig? The tutorial is whack and some of the services won't work after you install ISPConfig. The pure-ftpd TLS configuration step cannot be performed in the order that it appears in the tutorial.

Also note that the certificate created in the tutorial will NEVER be used by pure-ftpd. The correct certificate is automatically created for you in the /etc/pki/pure-ftpd directory.

Look at this:

http://www.howtoforge.com/forums/showthread.php?t=61221

cmsits 12th May 2013 19:17

Thanks :)
I have been studying centos & had a feeling I had not missed anything In the tutorial. Maybe it should be added at the end of the tutorial about TLS being turned off ?
Thanks :)

Hairy 12th May 2013 19:31

Quote:

Originally Posted by cmsits (Post 297114)
Thanks :)

No problem. Push the Thanks button. lol.

Quote:

Maybe it should be added at the end of the tutorial about TLS being turned off ?
In my opinion, the tutorial should be rewritten to add a step after you install ISPConfig that fixes mailman, dovecot, postfix, and pure-ftpd, as none of these will be working after you follow the tutorial and you install ISPConfig. The tutorial does have the step to fix mailman already after the install.

cmsits 16th May 2013 18:52

Hairy
thanks for the info

what are the fixes for
mailman, dovecot, postfix, and pure-ftpd

big thanks for all your help so far :)

Hairy 17th May 2013 20:42

Quote:

Originally Posted by cmsits (Post 297320)
Hairy
thanks for the info

what are the fixes for
mailman, dovecot, postfix, and pure-ftpd

big thanks for all your help so far :)

I am working on a tutorial for it. I have written 42 chapters, but I still have 4 more to go. Then, it still needs tested and feedback. I will send you what I have so far to your private messages. Please give me some feedback on it. Once it's complete, I want to submit it to the proper page where I can get a 12 month subscription to the forum in return.

cmsits 19th May 2013 01:35

will be happy to beta test it for you :)

crongm 24th May 2013 05:58

I'd also be happy to beta test or get some instructions. This is the first time I've had to install a server on a VPS, and it's driving me nuts. The bright side is: I've learned quite a few these last couple of weeks.


All times are GMT +2. The time now is 05:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.