HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   switching courier/maildrop to dovecot/sieve rules (http://www.howtoforge.com/forums/showthread.php?t=61795)

monkfish 10th May 2013 20:58

switching courier/maildrop to dovecot/sieve rules
 
Hello,

For performance reasons I just flipped a (Centos 6.4 x64 / ISPConfig 3.0.5.2) server from Courier to Dovecot. All the necessary folder changes were made, along with the server configuration System >> Server Config >> Server >> Mail and selecting Dovecot with Sieve.

Everything is working as expected, all clients and webmail users see all folders in correct places, etc. however users with mail filter rules seem to have a problem.

It seems that the .sieve ruleset initially written is structured for maildrop NOT sieve. Therefore I see parse errors such as:-

line 12: error: unexpected character(s) starting with '`'.

If I DISABLE then ENABLE the rule within ispconfig then it is written in the correct format and mail is filtered correctly.

Is this expected behaviour having to do this when flippng from one to the other?

Example is the following rule. Opened up .sieve file and inspected this which is showing in the logs as failing:-

Code:

### BEGIN FILTER_ID:50
`test -e "$DEFAULT/.oracle" && exit 1 || exit 0`
if ( $RETURNCODE != 1 )
{
        `maildirmake -f "oracle" $DEFAULT`
        `chmod -R 0700 "$DEFAULT/.oracle"`
        `echo "INBOX.oracle" >> $DEFAULT/courierimapsubscribed`
}
if (/^From: .*sup\-oracle@mydomain\.com/:h)
{
exception {
ID50EndFolder = "$DEFAULT/.oracle/"
to $ID50EndFolder
}
}
### END FILTER_ID:50

Edited the rule within the ISPConfig gui to disable it, saw it disappear from .sieve file then edited again to re-enable it. It reappeared as follows:-

Code:

### BEGIN FILTER_ID:50
if header :regex    ["from"] [".*sup\-oracle@mydomain\.com"] {
    fileinto "oracle";
    stop;
}
### END FILTER_ID:50

So while I've a feeling the "workaround" is to go through and disable all the rules and re-enable them, can I ask is this expected behaviour when flipping from courier to dovecot?

Thanks for ISPConfig

till 11th May 2013 18:13

Seems as if you switched without using the courier to dovecot conversion script. There are several threads here in the orum that describe how to migrate a server from courier to dovecot.

monkfish 11th May 2013 19:03

Ok, more research suggests I used a "generic" courier >> dovecot migration script and not one targeted for ISPConfig and thus missed out the mail filters.

I have actually found simply editing the rule and saving (without disabling/re-enabling) will cause it to be rewritten in correct sieve format, so thats something.

Just out of interest I see on the roadmap an item aimed at "resync rules", is there anything already I might be able to run to get all the rules rewritten in one go?

Cheers

Monk


All times are GMT +2. The time now is 06:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.