HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Sites & Ispconfig panel not workign after upgrade (http://www.howtoforge.com/forums/showthread.php?t=61723)

nunor 5th May 2013 19:48

Sites & Ispconfig panel not workign after upgrade
 
Hi,

I've upgraded Ubuntu server to 13.04.
Upgrade went fine, but all my websites & the ispconfig panel (on port 8080) are not reachable anymore.

I receive ERROR 500 - Internal Server Error! when trying to open the sites.
Strange is that all static domains & subdomains (without php) are working fine.
I checked the "The Perfect Server - Ubuntu 13.04" to be sure no additional steps has to be done, but I found nothing.

When I reload apache2 I have following warning (which I didn't had before)

[Sun May 05 19:44:58 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Sun May 05 19:44:58 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting [Sun May 05 19:44:59 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Sun May 05 19:44:59 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

Has anyone a clue what could be the issue?

Many thanks in advance,
Nuno



After some searching it looks like it's related to mod_fcgid. Is there any way to disable mod_fcgid?

below error.log from apache:
[Sun May 05 20:24:08 2013] [error] [client 85.93.202.65] Premature end of script headers: index.php
[Sun May 05 20:46:47 2013] [notice] caught SIGTERM, shutting down
[Sun May 05 20:46:48 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sun May 05 20:46:48 2013] [notice] Digest: generating secret for digest authentication ...
[Sun May 05 20:46:48 2013] [notice] Digest: done
[Sun May 05 20:46:48 2013] [notice] FastCGI: process manager initialized (pid 9802)
[Sun May 05 20:46:48 2013] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid
/2.3.7 PHP/5.4.9-4ubuntu2 mod_ssl/2.2.22 OpenSSL/1.0.1c configured -- resuming normal operations
[Sun May 05 20:47:11 2013] [notice] caught SIGTERM, shutting down
[Sun May 05 20:47:12 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sun May 05 20:47:12 2013] [notice] Digest: generating secret for digest authentication ...
[Sun May 05 20:47:12 2013] [notice] Digest: done
[Sun May 05 20:47:12 2013] [notice] FastCGI: process manager initialized (pid 9860)
[Sun May 05 20:47:13 2013] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid
/2.3.7 PHP/5.4.9-4ubuntu2 mod_ssl/2.2.22 OpenSSL/1.0.1c configured -- resuming normal operations

SamTzu 6th May 2013 11:56

[warn] is just a warning. It wont affect the control panel.
Your problem is with your SSL certificate. Did someone try to add SSL for the server? Have you configured additional IP addresses that those SSL's need?
Try running the php -q update.php for ISPConfig again to fix/re-install your controlpanel cert.


All times are GMT +2. The time now is 14:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.