HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Ubuntu 13.04 APS Problem (http://www.howtoforge.com/forums/showthread.php?t=61697)

MikeMcNuke 2nd May 2013 19:25

Ubuntu 13.04 APS Problem
 
Hi,

I installed ISPConfig with the help of this http://www.howtoforge.com/perfect-se...ot-ispconfig-3 tutorial.

One problem left: APS packages won't update or get populated at all.

Error code for every package available:

Code:

[INTERFACE]: APS crawler: Cannot read metadata from Xaraya-1.1.4-3.app.zip
Logfiles are not very helpful. 3 SimpleXML Warnings from PHP in lib/classes/aps_crawler.inc.php in Line 275:

Code:

$sxe = new SimpleXMLElement($xml);
But the XML gets generated.

The crawler is able to make directories in interface/web/sites/aps_meta_packages and places one file in every directory:

Example Directoryname: Zen Cart-1.5.1-10.app.zip
Filename in this directory: PKG_URL

Content of PKG_URL:
Code:

http://apscatalog.com/1/www.zen-cart.com/Zen%20Cart/1.5.1-10.aps?arch=undefined&packager=www.glowtouch.com&os=undefined&platform=undefined
But no packages get downloaded, all MySQL Tables for aps_*, except settings, are empty. Debug log from ISPConfig doesn't deliver any further information. php5-curl and cURL are installed.

But something is missing! Can anyone help me?

Thanks,
cya
Mike McNuke

till 2nd May 2013 19:36

Do you have a router or firewall in front of the server which might block access to apsstandard.org so that the packages cant be downloaded?

MikeMcNuke 2nd May 2013 19:44

Hi,

Firewall is installed on server, ufw with iptables. Server sits in some datahouse.

Also I tried a curl on apsstandards.org and apscatalog.com via ssh on the server.

Code:

curl apscatalog.com
curl apsstandard.org

and the data gets delivered to the shell.

MikeMcNuke 2nd May 2013 19:47

Just turned off ufw and flushed iptables. But no difference.

MikeMcNuke 2nd May 2013 22:35

Just digged a little deeper into aps_crawler.inc.php:

In the function public function startCrawler() it's able to fill the $apps_to_dl[] array with the correct information about Files.

But after this part of the function:

Code:

                //var_dump($apps);
               
                // For memory reasons, unset the current vendor and his apps
                unset($apps);

it seems to stop doing anything. Strange. memorylimit is 512MB, so this should be sufficient. How can I trace the problem further???

MikeMcNuke 2nd May 2013 23:03

Just did an update on a Ubuntu 12.10 Server from ISPConfig 3.0.5-rc2 to 3.0.5.2 . APS did work on rc2, but now the same problem. Damn. There must be some config problem.

frank81ita 3rd May 2013 16:51

APS Problem
 
Hi,
I'm having the same problem, but it's on Debian instead on Ubuntu (there aren't some differences).
Did you find a solution?
I tried to disable quota and some other stuffs, but I can't find a solution?
All downloads are working without any problem.
Best Regards
Francesco

MikeMcNuke 3rd May 2013 17:04

Until now no update on the problem.

Will install 2vms with ubuntu. One with older ispconfig one with new ispconfig. Perhaps I can find the error...

MikeMcNuke 4th May 2013 01:33

Problem fixed. I got back to my install files from ispconfig and ran the update script.

php -q update.php

Back in the frontend the APS packages get nowupdated and listed. But I don't know why. Did a backup of /etc before the update and compared all configs. No difference.

My Testinstalls on 2 VMs are also fully working.

Bad Hair... *hhmmm* Hosting Day???


All times are GMT +2. The time now is 15:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.