HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   noob samba question (http://www.howtoforge.com/forums/showthread.php?t=61690)

paarono 2nd May 2013 06:05

noob samba question
 
Hello, I am building a media server using samba and learning it at the same time. I followed the instructions here (http://www.howtoforge.com/ubuntu-12....tdbsam-backend) and am able to access the two account home directories using "smb://###/###/#/##/user" or using command-K (via OSX) to access the same URL.

So that all works, but in the tutorial it has you "mkdir -p /home/shares/allusers" What is this folder for and how do i access it? I tried variations of the above connection methods and can not seem to access this folder.

Any further explanation would be much appreciated.

Thank you!
paarono

martin1977 8th May 2013 19:51

It says in the howto that this is a common share folder for all users. The folder is created with mkdir -p /home/shares/allusers and then the appropriate rights are assigned with chown ... and chmod ...

paarono 10th May 2013 07:13

Hello martin1977, thanks for the reply!

The original issue i posted was that for what ever reason (perhaps i did not restart the service?) I was not able to see this allusers directory when logging in from OSX. I could access my home folder just fine.

Now I am able to see the allusers share from OSX but it will not let me access it. I get an error that is telling me

"the operation can not be completed because the original item for alluers can not be found" Any idea what this means?

I also decided I wanted to have this share folder on a different partition (a raid5 set up actually) and so i went through this tutorial again thinking that maybe i did something wrong and another go would fix my mistake. Now after changing the location here to a new path -
[allusers]
comment = All Users
path = /mnt/raid/share

i am still seeing the original allusers directory with the same error and the new directory is no where in sight.

Do i need to configure how OSX works with Samba? I tried accessing the allurers via another linux box i was able to set up also and it seemed to have no issues making this connection to the original share.

Cheers!

martin1977 10th May 2013 17:11

did you copy and paste
Code:

"the operation can not be completed because the original item for alluers can not be found"
?
If so, then you hay a typo in "alluers" which should be "allusers"
Also, after making changes you need to restart the samba service.

paarono 14th May 2013 07:00

Thanks again martin1977,

Turns out the typo was OSX auto correct so I was looking for the correct share after all. The problem i had was with permissions, the user I set up as part of the tutorial was not the user i was working with to test the share. I had to add my day to day user to the Users group.

Thank you for all the kind replies.


All times are GMT +2. The time now is 15:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.