HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   virtual-hosting-with-pureftpd-and-mysql (http://www.howtoforge.com/forums/showthread.php?t=61663)

Lord_Garfield 30th April 2013 12:51

virtual-hosting-with-pureftpd-and-mysql
 
Hi

I followed the tutorial: http://www.howtoforge.com/virtual-ho...-on-centos-6.2

But instead of centos 6.2 I have 6.3.

I also had to make a few changes for folowing reasons:

I have a /ierp/www/ierp folder wich has a "ln -s /ierp/www/ierp /var/www/html"
Becouse this will be my webroot

I want one user to have ftp access to /ierp/www
So in mysql database I have /ierp/www as homedir for that user.

mysql is also moved to /ierp/mysql and my socket is set to
MYSQLSocket /ierp/mysql/mysql.sock

mysql works fine after the replace (Owncloud is working on this server)

I also changed the bind parameter 0.0.0.0,21 to 0.0.0.0,10021
I listen on port 10021.
(And I opened this port in the firewall ofcource)

Now when I connect to the ftp server
<ip-adress>:10021
and I loggin with the username and password wich I created in the database.
It will login but I gives me the error that It can't open folderlist (this could be a bad translation of "Kan de mappenlijst niet openen")

I changed rights on the www folder like this:

groupadd ierp
usermod -a -G ierp apache
usermod -a -G ierp ftpuser
chown apache:ierp /ierp/www/ierp

Same result.

What did I do wrong?

Lord_Garfield 5th May 2013 23:17

Issue solved.

I forgot that it is passive FTP. So I opened the port range 30000:50000 and uncommented the passive port range in the config file. Now it all works!

mvg
Roel


All times are GMT +2. The time now is 07:05.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.