HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   error 500 after upgrade to ubunto 13.04 (http://www.howtoforge.com/forums/showthread.php?t=61653)

DUCKFACE 29th April 2013 20:46

error 500 after upgrade to ubunto 13.04
 
hello friends.
there is a problem on my server.
i upgrade it to ubunto 13.04 but i cant log in ispconfig. ov got Internal Server Error 500. here is apache2 log
Code:

SoftException in Application.cpp:299: Script "/usr/local/ispconfig/interface/web/index.php" resolving to "/usr/local/ispconfig/interface/web/index.php" not within configured docroot
Premature end of script headers: index.php

mod_php is working. any ideas ?

till 30th April 2013 08:34

Ensure that you use the correct url to access ispconfig, ispconfig has to be accessed over its port and not with /ispconfig

DUCKFACE 30th April 2013 19:47

yes im reaching it with https://www.mysite.com:8080/ but i still have that error 500

lee.veal 30th April 2013 22:10

can you post the out put of:

php -v

apache2 -V

DUCKFACE 1st May 2013 11:25

Quote:

Originally Posted by lee.veal (Post 296543)
can you post the out put of:

php -v

apache2 -V

PHP 5.4.9-4ubuntu2 (cli) (built: Mar 11 2013 16:09:26)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
with XCache v2.0.0, Copyright (c) 2005-2012, by mOo


Server version: Apache/2.2.22 (Ubuntu)
Server built: Mar 15 2013 14:02:11
Server's Module Magic Number: 20051115:30
Server loaded: APR 1.4.6, APR-Util 1.4.1
Compiled using: APR 1.4.6, APR-Util 1.4.1
Architecture: 64-bit
Server MPM: Prefork
threaded: no
forked: yes (variable process count)
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D DYNAMIC_MODULE_LIMIT=128
-D HTTPD_ROOT="/etc/apache2"
-D SUEXEC_BIN="/usr/lib/apache2/suexec"
-D DEFAULT_PIDLOG="/var/run/apache2.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/apache2/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="mime.types"
-D SERVER_CONFIG_FILE="apache2.conf"

lee.veal 1st May 2013 15:55

Have you tried disabling xcache ?

In your php.ini file it should look something like this.

;extension = xcache.so

Also check your file permissions, as that can sometimes cause this error

till 1st May 2013 16:01

Did you rerun the ispconfig update after updating ubuntu? If not, it might be that the ubuntu update changed any config files. download ispconfig again, run the update.php script which is in the install folder and choose to reconfigure permissions during update.

DUCKFACE 1st May 2013 17:12

after update.php problem is solved. but now i see that in monitoring site mysql is turned off but its actualy working.
the other strange thing is that
PHP Warning: Illegal string offset 'output' in /usr/local/ispconfig/server/mods-available/monitor_core_module.inc.php on line 707

till 1st May 2013 17:17

ensure that mysql listens also on IP 127.0.0.1.

DUCKFACE 1st May 2013 20:27

its listentnig on 127.0.0.1 too
as i see IMAP is stopped too.
after upgrade i cant send emails too...
here is error log from mail server

Code:

May  1 20:01:30 server dovecot: auth-worker(15391): mysql(localhost): Connected to database dbispconfig
May  1 20:01:30 server dovecot: imap-login: Login: user=<office@mysite.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=15393, secured, session=<3gnCEavbvQB/AAAB>
May  1 20:01:30 server dovecot: imap(office@mysite.com): Disconnected: Logged out in=79 out=710
May  1 20:02:19 server postfix/smtpd[15430]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
May  1 20:02:19 server postfix/smtpd[15430]: connect from localhost[127.0.0.1]
May  1 20:02:19 server postfix/smtpd[15430]: warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)
May  1 20:02:19 server postfix/smtpd[15430]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
May  1 20:02:19 server postfix/smtpd[15430]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 451 4.3.5 <localhost[127.0.0.1]>: Client host rejected: Server configuration error; from=<office@mysitecom> to=<office@mysite.com> proto=ESMTP helo=<mysite.com>
May  1 20:02:19 server postfix/smtpd[15430]: lost connection after RCPT from localhost[127.0.0.1]
May  1 20:02:19 server postfix/smtpd[15430]: disconnect from localhost[127.0.0.1]
May  1 20:02:21 server postfix/smtpd[15430]: connect from localhost[127.0.0.1]
May  1 20:02:21 server postfix/smtpd[15430]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
May  1 20:02:21 server postfix/smtpd[15430]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 451 4.3.5 <localhost[127.0.0.1]>: Client host rejected: Server configuration error; from=<office@mysite.com> to=<office@mysite.com> proto=ESMTP helo=<mysite.com>
May  1 20:02:21 server postfix/smtpd[15430]: lost connection after RCPT from localhost[127.0.0.1]
May  1 20:02:21 server postfix/smtpd[15430]: disconnect from localhost[127.0.0.1]



All times are GMT +2. The time now is 11:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.