HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   FTP issue after ISPconfig upgrade (http://www.howtoforge.com/forums/showthread.php?t=6163)

palkat 12th August 2006 19:01

FTP issue after ISPconfig upgrade
 
So upgraded from 2.1.9 to 2.2.6 with no hitches...so i thought.

Now the ftp does not work. I have tested on computers outside my network and computers on the same network as my ISPconfig server.

The only way i can connect via ftp is on a pc with in my network and give the ftp address for the server (IE: 192.168.1.200)

as for ftp'ing using url's on my network and outside my network i get the following message:
Code:

[09:53:15] SmartFTP v2.0.994.8
[09:53:15] Resolving host name "cwhs.oneillpcs.com"
[09:53:15] Connecting to 24.117.228.198 Port: 21
[09:53:16] Connected to cwhs.oneillpcs.com.
[09:53:16] 220 ProFTPD 1.2.10 Server (ProFTPD Default Installation) [192.168.1.200]
[09:53:16] USER homeschooldiary.com_admin
[09:53:16] 331 Password required for homeschooldiary.com_admin.
[09:53:16] PASS (hidden)
[09:53:16] 230 User homeschooldiary.com_admin logged in.
[09:53:16] SYST
[09:53:16] 215 UNIX Type: L8
[09:53:16] FEAT
[09:53:16] 211-Features:
[09:53:16]  MDTM
[09:53:16]  REST STREAM
[09:53:16]  SIZE
[09:53:16] 211 End
[09:53:16] PWD
[09:53:16] 257 "/" is current directory.
[09:53:16] TYPE A
[09:53:16] 200 Type set to A
[09:53:16] PASV
[09:53:16] 227 Entering Passive Mode (192,168,1,200,128,92).
[09:53:16] Opening data connection to 192.168.1.200 Port: 32860
[09:53:16] LIST -aL
[09:53:37] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[09:54:17] Timeout (40s).
[09:54:17] Active Help: http://www.smartftp.com/support/kb/index.php/74
[09:54:17] Client closed the connection.

I have used several differant FTP clients to all with the same issue.

Now in the past i had set my etc/proftpd.conf file to use masqueradeaddress and that was working up till the ispconfig upgrade. the masqueradeaddress in the etc/proftpd.conf is still there.

Looking at the above code/log of a ftp client outside the network it look like the masqueradeaddress is not working as it show the servers network ip of 192.168.1.200. How ever when i restart the proftpd daemon it show the masquerade is working pointing to my domain ip and not the server ip.

Any ideas why the ftp is not working???

Thanks!

till 13th August 2006 14:03

Please try to comment out the include of the config file generated by ISPConfig at the end of your proftpd.conf and restart proftpd.


All times are GMT +2. The time now is 16:10.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.