HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   OpenVPN and BIND Issue (http://www.howtoforge.com/forums/showthread.php?t=61583)

dexiom 24th April 2013 00:59

OpenVPN and BIND Issue
 
Hi guys i have a trouble with my BIND DNS server, i have a webserver installed as in the "The perfect Debian Server with ISPConfig (Squeeze)", almost everything was going fine, the important thing is tha DNS was working and queries to my domain "dexiom.mx" and any other domain i had authority over were properly resolved by my DNS server, yesterday i decided to hire a VPN service (StrongVPN) and got an OpneVPN package, i have my server now running on the VPN IP Addres 207.204.236.242 but my DNS server is not resolving DNS queries anymore, i think it is a problem of the VPN connection but honestly i dont know much about VPN's. I have tried

Quote:

davidlaredo@davidlaredo-Latitude-E5420:~$ telnet 207.204.236.242 53
Trying 207.204.236.242...
Connected to 207.204.236.242.
Escape character is '^]'.
I have also tested

Quote:

davidlaredo@davidlaredo-Latitude-E5420:~$ dig @207.204.236.242 dexiom.mx any

; <<>> DiG 9.8.1-P1 <<>> @207.204.236.242 dexiom.mx any
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached
and

Quote:

davidlaredo@davidlaredo-Latitude-E5420:~$ host www.dexiom.mx
Host www.dexiom.mx not found: 2(SERVFAIL)
if i run a dig query on the server it shows

Quote:

administrator@server1:~$ dig @localhost dexiom.mx any

; <<>> DiG 9.7.3 <<>> @localhost dexiom.mx any
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37153
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;dexiom.mx. IN ANY

;; ANSWER SECTION:
dexiom.mx. 172800 IN SOA server1.dexiom.mx. postmaster.dexiom.mx. 2013042304 3600 300 604800 1800
dexiom.mx. 172800 IN MX 10 server1.dexiom.mx.
dexiom.mx. 0 IN NS server1.dexiom.mx.

;; ADDITIONAL SECTION:
server1.dexiom.mx. 172800 IN A 207.204.236.242

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Apr 23 17:53:11 2013
;; MSG SIZE rcvd: 128
I can acces the server via ssh using the ip address and I can even acces the ispconfig control panel with the ip address too so i think its a misconfiguration of BIND.

Please help


All times are GMT +2. The time now is 02:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.