HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Since upgrade to newest ispconfig I can't create folders (http://www.howtoforge.com/forums/showthread.php?t=61560)

happz 22nd April 2013 02:43

Since upgrade to newest ispconfig I can't create folders
 
I'm at /var/www/clients/client1/web1 and I logged into WinSCP and tried to create a folder at /var/www/clients/client1/web1/>here< and I'm doing it as root but no go. From filezilla, as the web user, I tried also but get the same issue.

Anyone else?

thanks,
Happz

florian030 22nd April 2013 06:34

See http://www.howtoforge.com/forums/showthread.php?t=60974

happz 22nd April 2013 17:04

Thanks..
 
I went through the post quickly but ADM asked on the very last post- how to fix it? Maybe I missed the answer but ADM hasn't found a solution either.

From ADM:
Code:

Is it working as intended that root user can't make dirs inside /home/www/clients/clientN/webN/ dir?

Or it is a side effect of this /etc/fstab manipulation?

Thank you greatly, and I'll keep reading that post again...

happz

florian030 22nd April 2013 18:14

You can disable the immutable-attribute in server config / web

happz 22nd April 2013 20:15

Wonderful. Thanks ....oh, are the instructions listed in the forum thread?

Thanks,
happz

darinpeterson 23rd April 2013 02:56

As Falko told me, you can change this behavior under System > Server Configuration > Web > Permissions.

happz 23rd April 2013 03:10

wonderful
 
And which on/off toggles did you do?

darinpeterson 23rd April 2013 15:36

Hi happz,

System > Server Config, then I selected the server that I wanted to alter settings for, then clicked on the Web tab, scrolled to the bottom where Permissions exist. Then uncheck "Make web folders immutable".

This will allow you to create folders. Don't forget to give it a minute before you try making folders.

That should do it...

Darin

happz 23rd April 2013 16:17

I did it last night and today, I still have the issue but I'm in filezilla...I'll try winscp next. Here's my settings:

Set folder permissions on update [on]

Make web folders immutable (extended attributes) [off]

Add web users to -sshusers- group [on]

Connect Linux userid to webid [off]

Start ID for userid/webid connect [1000]

Thx

till 23rd April 2013 17:06

This setting will get applied to new or changed sites only. If you want to apply new general settings to all existing sites, use the resync tool.


All times are GMT +2. The time now is 06:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.