HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Apache not starting after installing SSL certificate on a website (http://www.howtoforge.com/forums/showthread.php?t=61519)

Tarm 19th April 2013 08:01

Apache not starting after installing SSL certificate on a website
 
Hello!

I tried to install a already existing certificate from GoDaddy on a website in ISPConfig3. I first enabled the SSL checkbox, then copy/pasted the certificate in the SSL tab.

After I did this, apache crashed, and could not start. I'll admit I panicked a bit, but further on I navigated to /var/www/example.com/ssl, and deleted the certificates. I tried to restart apache, but then it could not find the certificates, and would not start (obviously). I went in /etc/apache2/sites-enabled/100-example.com vhost, and removed the certificate paths from:

Code:


    <IfModule mod_ssl.c>
#      SSLEngine on

    </IfModule>

I then tried restarting apache, but now I'm getting this error message in apache:

[Fri Apr 19 07:57:49 2013] [error] Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)

Any suggestions? Thanks!

till 19th April 2013 14:58

To install a existing ssl cert, you have to copy / paste the cert and the key into the cert and key fields on the ssl tab of the website.

Tarm 19th April 2013 15:25

Hello,

yes, I did that, but somehow Apache crashed afterwards. The apache process went down, and won't start up again, and the last error I'm getting is:
[Fri Apr 19 07:57:49 2013] [error] Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)

I tried to remove the certificates from the vhost (/var/www/example.com/ssl), and in the vhost file (/etc/apache2/sites-enabled/example.com vhost), to redo the changes with the certificate (i.e use none certificate for the website).

till 19th April 2013 15:53

Delete the link to the vhost file in the sites-enabled folder and then restart apache, you should be able tologin to ispconfig again then and redo the ssl setup.

Tarm 19th April 2013 16:01

Thanks! That did it. I appreciate the help :- ) You should have a donate button in your signature.

till 19th April 2013 16:18

Quote:

Originally Posted by Tarm (Post 296025)
Thanks! That did it. I appreciate the help :- ) You should have a donate button in your signature.

If you like to donate to the ispconfig project and supports its further development and enable us to contine with support that we do here at the forum, then please consider to buy a howtoforge subscription:

http://www.howtoforge.com/subscription


All times are GMT +2. The time now is 17:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.