HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig 3.0.5.2 not loading - blank page - bug maybe (http://www.howtoforge.com/forums/showthread.php?t=61506)

tahunasky 18th April 2013 04:13

ISPConfig 3.0.5.2 not loading - blank page - bug maybe
 
Hi,

i am getting the following error:

Quote:

[Thu Apr 18 12:49:01 2013] [error] [client 10.0.0.13] PHP Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
[Thu Apr 18 12:49:01 2013] [error] [client 10.0.0.13] PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31
I have just installed the latest version on ubuntu 12.10.
It worked after first install then stopped working after server reboot.

I fixed by changing the permissions on:

/usr/local/ispconfig/interface/lib/config.inc.php

from 600 to 750.

Is this correct ?
Why is this happening ?
Is it a bug ?

thanks

till 18th April 2013 09:06

The correct permissions are 600 and not 750 and what you describe is a configuration issue of your server and not a bug in ispconfig. Php fcgi with suexec is not working correctly on your system and when suexec fails, then you can not access this file enymore. Ensure that suexec is installed and enabled. This happened most likely because you or another admin of that server changed the apache configuration without restarting apache so you recognized the issue after the reboot.

tahunasky 18th April 2013 11:46

Hi till..

I did change apache configs, or to be more exact, i copied over sites_available and sites_enabled configs from a 3.0.4.6 server with same version of ubuntu server.

Anyways will do another install and modify the existing files on the new install and let you know if it was me over writing the config files stuffed it up.

thanks for the help/info

till 18th April 2013 12:06

Ok, then I guess you copied over the ispconfig.conf and ispconfig.vhost files as well, the ones from3.0.4.6 are incompatible iwth 3.0.5, so if you repkace the 3.0.5. files, the system will fail.


All times are GMT +2. The time now is 15:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.