HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Cannot flush mail queue - mail system is down (http://www.howtoforge.com/forums/showthread.php?t=61341)

gleidsonlm 8th April 2013 17:35

Cannot flush mail queue - mail system is down
 
Postfix isn't sending messages, I got this error trying to queue:

Code:

# postqueue -vf
postqueue: name_mask: all
postqueue: inet_addr_local: configured 2 IPv4 addresses
postqueue: inet_addr_local: configured 2 IPv6 addresses
postqueue: fifo_trigger: open public/qmgr: cannot open file: No such device or address
postqueue: fatal: Cannot flush mail queue - mail system is down

I found two files with qmgr in name, but they look ok about user and file permissions.

Code:

# find / -iname qmgr -exec ls -la {} \;
-rwxr-xr-x 1 postfix postfix 67520 2011-10-07 01:20 /usr/lib/postfix/qmgr
prwxr-xr-x 1 postfix postdrop 0 2013-04-04 19:30 /var/spool/postfix/public/qmgr

postfix check returns all good

Code:

# postfix -v check
postfix: name_mask: all
postfix: inet_addr_local: configured 2 IPv4 addresses
postfix: inet_addr_local: configured 2 IPv6 addresses

Enviroment:
Ubuntu 11.10 oneiric
Postfix 2.8.5-2~build1
Installed with ISPConfig3 using Howtoforge server perfect setup.

Mail Error Log:

Code:

Apr  8 12:28:11 ip-10-252-142-252 postfix/smtpd[11567]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Apr  8 12:30:07 ip-10-252-142-252 postfix/pickup[11740]: fatal: connect #11 to subsystem public/cleanup: Connection refused
Apr  8 12:30:52 ip-10-252-142-252 postfix/smtpd[11806]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Apr  8 15:30:53 ip-10-252-142-252 postfix/postqueue[11976]: fatal: Cannot flush mail queue - mail system is down
Apr  8 12:32:48 ip-10-252-142-252 postfix/pickup[12030]: fatal: connect #11 to subsystem public/cleanup: Connection refused
Apr  8 12:33:33 ip-10-252-142-252 postfix/smtpd[12057]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Apr  8 15:33:37 ip-10-252-142-252 postfix/postqueue[12392]: fatal: Cannot flush mail queue - mail system is down
Apr  8 12:35:29 ip-10-252-142-252 postfix/pickup[12396]: fatal: connect #11 to subsystem public/cleanup: Connection refused
Apr  8 12:36:14 ip-10-252-142-252 postfix/smtpd[12472]: fatal: connect #11 to subsystem private/proxymap: Connection refused

all services running, but postfix:

Code:

# service amavis status
 * amavisd is running
# service clamav-daemon status
 * clamd is running
# service postfix status
 * postfix is not running

What should I looking for fix this?

darinpeterson 8th April 2013 20:05

I'm not quite sure where to start with this one, so do you get any errors when you do:

Code:

/etc/init.d/postfix start

gleidsonlm 8th April 2013 21:06

Thanks for awsering, but any erros showed:

Code:

# /etc/init.d/postfix start
 * Starting Postfix Mail Transport Agent postfix                                                                                                                                                        [ OK ]

But when I seek for status:

Code:

# /etc/init.d/postfix status
 * postfix is not running

End again, same error...

Code:

postqueue: name_mask: all
postqueue: inet_addr_local: configured 2 IPv4 addresses
postqueue: inet_addr_local: configured 2 IPv6 addresses
postqueue: fifo_trigger: open public/qmgr: cannot open file: No such device or address
postqueue: fatal: Cannot flush mail queue - mail system is down


darinpeterson 9th April 2013 02:08

I'm sorry. I don't know. Hopefully someone else with more background with postfix will see this, and help.

gleidsonlm 9th April 2013 12:54

I tried to "purge" all packages related and reinstall, but any effect.

I just finish to look this post quoted at perfect server howto, but also any effect.
http://www.howtoforge.com/forums/sho...1&postcount=25

Right now, I'm kind of scary about this... the queue sums up 10k messages and nothing I do can send them. If someone has a hint about what should I looking after, please tell me.


All times are GMT +2. The time now is 07:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.