HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   mysql root login (http://www.howtoforge.com/forums/showthread.php?t=61316)

cwtudor 5th April 2013 23:04

mysql root login
 
unable to login as root, mysql seems to be running fine. I can login to a database just not as root.

root@shv:~# mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)


Try to stop mysql so I could start in safe mode with no luck. I get this

root@shv:~# /etc/init.d/mysql stop
Stopping MySQL database server: mysqld failed!.


what does daemon.error mean here

root@shv:~# ps ax | grep mysql
719 ? Sl 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306
720 ? S 0:00 logger -t mysqld -p daemon.error
805 pts/0 S+ 0:00 grep mysql
1442 ? S 0:00 /bin/sh /usr/bin/mysqld_safe

this should be my password.
root@shv:~# cat /usr/local/ispconfig/server/lib/mysql_clientdb.conf
<?php

$clientdb_host = 'localhost';
$clientdb_user = 'root';
$clientdb_password = 'imhotep';

?>

can not login as admin it ISP Config now either. HELP Please

darinpeterson 6th April 2013 06:39

I had a similar problem. Maybe see here to find a solution: http://stackoverflow.com/questions/1...317679_6927879

Regards,
Darin

cwtudor 8th April 2013 15:26

can not log in as root
 
Sorry none of the suggestions worked. Can not log in as root and can not stop mysql service.

cwtudor 8th April 2013 16:00

Thanks got it fixed
 
Thanks for all the help. I was able to fix the problem this morning. Using pkill -p mysql I was able to stop mysql. I was afraid to try this before because I did not want to lose any data, but it worked without any loss. So Thanks for answer Darin.

darinpeterson 8th April 2013 19:58

Sure. Glad it worked for you...

Regards,
Darin


All times are GMT +2. The time now is 19:13.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.