HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Websites works locally but not from the outside! I call upon the Experts to do magic (http://www.howtoforge.com/forums/showthread.php?t=61301)

danhansen@denmark 5th April 2013 04:58

Websites works locally but not from the outside! I call upon the Experts to do magic
 
Hi,

I will try to explain my problem to the letter. Right now I would just like an answer if it is possible to do what I am trying to do at all :o

Here's some info:

---------------------------------------------------------------------------------------------
Internet Service Information:
Fast Internet Line/Used only for Internet-Server.
Static/Fixed public IP
All ports opened in router --> server ip number (local ip)
Primary nameserver --> ns1.mynameserver.tld
Secondary nameserver --> ns2.somedanishdomainservice.tld

NAT/Firewall (But open and portforwarding all to myserveripnumber)

System Information:
Ubuntu Server 10.04
ISPconfig 3 v.3.0.5.2
Single Server Setup (running primary nameserver)
Tutorial: The Perfect Server - ISPConfig3 - Ubuntu Server 10.04:
http://www.howtoforge.com/perfect-se...nx-ispconfig-3
Downloaded Manual for ISPConfig3 by Falko Timme
---------------------------------------------------------------------------------------------

Followed the tutorial:
http://www.howtoforge.com/perfect-se...nx-ispconfig-3

Followed the tutorial:
http://www.howtoforge.com/ispconfig_...domain_schlund

So I have my own primary nameserver - but with a local ipnumber instead of a public ip number. Isn't it possible? My primary nameserver has been approved by the danish top level domain provider (dk-hostmaster.dk) and all domains are setup to ns1.myprimarynameserver.tld (ispconfig3) and ns2.somedanishnameserverservice.tld and this works as well. But when using the fixed ipnumber in my nameserver's A-records I can't reach the websites. But changing to myserverslocalip makes the websites work locally. I have been triyng, reeding and requesting anywhere to solve this problem. Is there someone of you Experts that will look into my problem and help me solve this? I will be standing by for 36 hours straight, ready to answer any question there may be.
I am so much looking forward to program my new internetshop. Please help me get the server to run :o

I will insert some additional information below. First the A-records for the domain that is used for the nameserver. The nameserver is therefore hosting its own domain, just as described in the second tutorial above. A-records which make the website reachable locally, not from the outside:

A mydomain.tld. 192.168.1.200 0 3600
A mail 192.168.1.200 0 3600
A ns1 192.168.1.200 0 86400
A www 192.168.1.200 0 3600
MX mydomain.tld. mail.mydomain.tld. 10 3600
NS mydomain.tld. ns1.mynameserver.tld. 0 3600
NS mydomain.tld. ns2.somesecondarydns.dk.0 3600


Here's proof that the websites works after changing A-records to the local serveripnumber ! But only locally, not from the outside.

Welcome to your website!
This file may be deleted or overwritten without any difficulty. This is produced........
Powered by ISPConfig


And I know these A-records f..... up the nameserver, as a matter of fact, the nameserver does not answer upon a lookup right now, so I will change the the A-records back to the Fixed/public ipnumber again. It's just that after I changed the A-records to the serveripnumber as shown above, it worked, from the outside as well. But after a few hours, the nameservers has been updates with the faulty A-records, and it stopped working and only worked locally (inside my lan). So now I will change the A-records back to the fixed/public ipnumber and the the website cant be reached locally anymore.

Idea: Is it possible with a combination of the dns-records? Is this the way? Isn't there suppose to be any dns records which points to the serveripnumber?
Idea: What about another type of record that will show "the way" to the myserveripnumber - a SRV-record? I read something about this record in the manual, a server record, but I can't figure it out? I'm just getting too mixed up in my hed :confused:

For further information I will insert my /etc/resolv.conf file below as well, maybe theres a error there?:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
nameserver 192.168.1.1
domain home
search home
~
~
[...]


Here is a link to a thread were there are talk about local ip and nameserver/ispconfig - but I haven't got the knowhow to see if this is the solution. I thing maybe not.:
http://www.howtoforge.com/forums/sho...129#post235129

Here is another thread were we are discussing the same issue: http://www.howtoforge.com/forums/sho...385#post295385

Well, thats all, nothing much... " 2hours 20minutes of trying to explain my problem. Hope there is a kind soal out there.. Signing of untill 7 am.


Kind Regards,
Dan

danhansen@denmark 8th April 2013 19:02

Hi,

This problem has been solved..
Thanks.

Kind Regards
Dan

skoena 9th April 2013 06:34

What was the solution?

danhansen@denmark 9th April 2013 13:04

The solution! A securitybreach in the "Sagem" Modem/Router from the danish ISP TDC
 
Hi Skoena,

The solution was a securitybreach in the "Sagem" Modem/Router from the danish ISP TDC
It's several things combinated - but not at all a fix I think any of you can use at all. But, if in doubt, please don't hesitate to ask me :)
I tried to explain both the problem and the solution on this site: http://www.howtoforge.com/forums/showthread.php?t=61335

Thanks for asking ;)

Kind Regards,
Dan


All times are GMT +2. The time now is 18:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.