HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Mail Server Memory Allocation Problems and Table Lookup Issues (http://www.howtoforge.com/forums/showthread.php?t=61193)

darinpeterson 28th March 2013 14:54

Mail Server Memory Allocation Problems and Table Lookup Issues
 
I have installed an OpenVZ server on Debian Squeeze. The virtual server has 8GB RAM, 586GB hard disk space, and I'm having forking issues with amavis. At times I go into the virtual server using vzctl enter mail, and begin getting fork errors right away.

Additionally there seems to be a lock issue with mysql.

Here are the results of: netstat -tap | grep mysql
root@mail:/# netstat -tap | grep mysql
tcp 0 0 *:mysql *:* LISTEN 1393/mysqld
tcp 0 0 localhost:34323 localhost:mysql ESTABLISHED 2090/smtp
tcp 0 0 localhost:mysql localhost:34322 ESTABLISHED 1393/mysqld
tcp 0 0 mail.domain:52579 www.domain.:mysql TIME_WAIT -
tcp 0 0 localhost:mysql localhost:34326 ESTABLISHED 1393/mysqld
tcp 0 0 localhost:34322 localhost:mysql ESTABLISHED 2089/smtp
tcp 0 0 localhost:mysql localhost:34323 ESTABLISHED 1393/mysqld
tcp 0 0 localhost:34326 localhost:mysql ESTABLISHED 2094/error

Here is the tail of my mail error log:
Mar 28 09:23:31 mail postfix/trivial-rewrite[1334]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 28 09:23:33 mail postfix/trivial-rewrite[1413]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem

I don't understand why I'm still having issues with 8GB of memory allocated:
root@mail:/# free
total used free shared buffers cached
Mem: 8388608 582428 7806180 0 0 0
-/+ buffers/cache: 582428 7806180
Swap: 0 0 0

Can anyone help?

Thanks,
Darin

todgerme 28th March 2013 23:55

Have a look in the syslog and your beancounters and look for resource shortages.

Allocating 8GB isn't enough for openvz, you'll probably need to increase kmemsize, and the various tcpsnd|rcvbuf will need upped as well.

darinpeterson 29th March 2013 00:36

Quote:

Originally Posted by todgerme (Post 294959)
Have a look in the syslog and your beancounters and look for resource shortages.

Allocating 8GB isn't enough for openvz, you'll probably need to increase kmemsize, and the various tcpsnd|rcvbuf will need upped as well.

Hi Tod,

So my hardware node has 24GB I am running 8GB on the mail server node only. You're saying that isn't enough? Wow, I thought that should be more than enough. What is considered enough?

Thanks,
Darin


All times are GMT +2. The time now is 18:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.