HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Resolvconf Problem - cannot set nameservers (http://www.howtoforge.com/forums/showthread.php?t=61191)

sheshes 28th March 2013 14:25

Resolvconf Problem - cannot set nameservers
 
I am running Ubuntu 12.10 with ISPConfig 3.0.5.1.

I am trying to setup my ISPs nameservers but resolv.conf is never changing. It's stuck on nameserver 127.0.0.1

I tried editing /etc/network/interfaces and inserted dns-nameservers xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx then resolvconf -u and then ifdown eth0 && ifup eth0. No result

I tried editing /etc/resolvconf/resolvconf.d/base with same parameters, again no result.

I tried disabling resolvconf updates as well as edit the dhcpclient.conf in both /etc/dhcp and /etc/dhcp3 with the prepent-domain again no result.

I'm already frustrated enough and cannot think of anything else to try. I tried google but all the solutions proposed are mentioned above and don't work.

Any help is appreciated

DKLeader 28th March 2013 14:57

Do you have a resolv.conf in /etc/?
I am using Debian Squeeze and had to manually add them.

sheshes 28th March 2013 15:22

yes I do, since ubuntu 12.04 onwards resolv.conf cannot be updated manually!

sheshes 28th March 2013 18:52

Update: I have removed /etc/resolv.conf and run dpkg-reconfigure resolvconf and answered yes to all of the options. The result was that now /etc/resolv.conf is correctly created as a symlink, but still not able to update it as I want to

arisystems 29th March 2013 19:28

Does the NIC have the public IP4 address. I never used Comcast name server IPs when the NIC is the public facing IP. Post the interfaces file... another set of eyes...

TiTex 29th March 2013 20:56

could it be because you have you NIC configured to get IP from DHCP server ?
if so ... dhclient will automaticly update resolv.conf no matter what you've set manually.

by the way /etc/resolv.conf is a symlink for /etc/resolvconf/run/resolv.conf if i'm not mistaken

so i guess you can solve your problem by removing the symlink and create a normal conf file or add a write protect bit to resolv.conf after you've modified it
Code:

chattr +i /etc/resolv.conf

pititis 30th March 2013 00:13

Quote:

echo "nameserver 8.8.8.8" >TEST
To add this nameserver:
Quote:

cat TEST | resolvconf -a eth0
To delete this nameserver:
Quote:

cat TEST | resolvconf -d eth0
eth0 = interface

Try it.

sheshes 1st April 2013 14:10

TiTex & Pititis thanks for your answers.

TiTex my interface is set to static with an added dns-nameservers line as man resolvconf states. dhcp is not enabled. I want to make this work the proper way as I do a lot of update && distro upgrades and it keeps breaking up if everything is not done properly.

Pititis I tried what you suggested. Unfortunately nothing is added in /etc/resolv.conf. It's stuck at nameservers 127.0.0.1

any other suggestions?

arisystems 1st April 2013 14:57

One more time...
 
Post the interfaces file. Odds are there is a simple error in it. If nothing else I will cut-n-paste it and try it in a server running here.

sheshes 2nd April 2013 17:25

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 172.16.2.100
netmask 255.255.255.0
gateway 172.16.2.1
network 172.16.2.0
broadcast 172.16.2.255
dns-nameservers 213.140.208.226 213.140.209.226


All times are GMT +2. The time now is 08:05.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.