HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPConfig 3.0.5.2 released (http://www.howtoforge.com/forums/showthread.php?t=61190)

till 28th March 2013 15:15

ISPConfig 3.0.5.2 released
 
ISPConfig 3.0.5.2 is available for download. This release is a bugfix release for ISPConfig 3.0.5.

For a detailed list of changes, please see the changelog section below.

================================================== ===
*** New! The ISPConfig 3 manual for ISPConfig 3.0.5 is now available! ***

Version 1.4 for ISPConfig >= 3.0.5 (Date: 02/22/2013)
Author: Falko Timme <ft@falkotimme.com>

373 pages

The manual can be downloaded from these two links:

http://www.ispconfig.org/ispconfig-3...nfig-3-manual/
http://www.howtoforge.com/download-t...onfig-3-manual
================================================== ===

-----------------------------------------------------
- Download
-----------------------------------------------------

The software can be downloaded here:

http://prdownloads.sourceforge.net/i...3.0.5.2.tar.gz

------------------------------------
- Changelog
------------------------------------

http://bugtracker.ispconfig.org/inde...&status[]=

--------------------------------------
- Known Issues:
--------------------------------------

Please take a look at the bugtracker:

http://bugtracker.ispconfig.org

--------------------------------------
- BUG Reporting
--------------------------------------

Please report bugs to the ISPConfig bugtracking system:

http://bugtracker.ispconfig.org

----------------------------------------
- Supported Linux Distributions
----------------------------------------

- Debian Etch (4.0) - Squeeze (6.0) and Debian testing
- Ubuntu 7.10 - 12.10
- OpenSuSE 11 - 12.2
- CentOS 5.2 - 6.4
- Fedora 9 - 15

-----------------------------------------
- Installation
-----------------------------------------

The installation instructions for ISPConfig can be found here:

http://www.ispconfig.org/ispconfig-3/documentation/

or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

------------------------------------------
- Update
------------------------------------------

To update existing ISPConfig 3 installations, run this command on the shell:

ispconfig_update.sh

Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

Detailed instructions for making a backup before you update can be found here:

http://www.faqforge.com/linux/contro...e-ispconfig-3/

If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

-------------------------------------------
- Manual update instructions
-------------------------------------------

Code:

cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php


dynamind 28th March 2013 16:17

ssl warning after updating
 
hello,

thanks, now apache2 shows:

user@ws:~# /etc/init.d/apache2 restart
Restarting web server: apache2[Thu Mar 28 15:12:22 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Thu Mar 28 15:12:22 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting [Thu Mar 28 15:12:23 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Thu Mar 28 15:12:23 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
.

ports.conf holds:

Quote:

# cat /etc/apache2/ports.conf
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>
I tried the ln -s command from your post but no fx

frankbootmaker 28th March 2013 18:33

Same problem...
 
Hi,

I have the same symptom, my system runs on debian squeeze. Altough all sites appear to work fine this warning message is annoying... could we somehow get rid off it like it wasn't there in the earlier versions...

Thank you,
Feri

contremaitre 28th March 2013 19:20

is there any way we can still use the global search function with the dashboard module disabled?

falko 28th March 2013 20:13

You can ignore the NameVirtualHost warnings, they do no harm to your systems.

ADM 28th March 2013 21:25

Same issue here with Debian 6.0.7

Code:

[warn] NameVirtualHost *:80 has no VirtualHosts
Apache works but this warning should be fixed, thanks.

zuyan 28th March 2013 23:18

Ubuntu 12.04.2 is show same message.
Quote:

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) and then start(8) utilities,
e.g. stop dovecot ; start dovecot. The restart(8) utility is also available.
dovecot stop/waiting
dovecot start/running, process 4585
* Restarting web server apache2
[Fri Mar 29 05:08:25 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Mar 29 05:08:25 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[Fri Mar 29 05:08:26 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Mar 29 05:08:26 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting ...done.
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -E -8 UTF-8 -D -A -Y 1 -O clf:/var/log/pure-ftpd/transfer.log -u 1000 -H -B
Update finished.
root@main:/tmp/ispconfig3_install/install#

MaddinXx 28th March 2013 23:25

Hi falko

My Nginx reverse proxy plugin stopped working (queue doesn't procees) (manually running server.sh doesn't to anything).

I've seen that the plugins-core dir is new as well as some changes in lib/plugins.inc.php but I was not able to find the code that has to be changed.

Are there any known code parts that need to be rewritten in plugins?

Thanks!

// edit: Problem spotted. My classes/ dir now has to be placed outside of plugins-available

Torch_za 29th March 2013 00:08

Once again, a big up to Till & Co for an outstanding application which has become progressively better since I first installed 3 many years ago.

I have a client with a Debian Squeeze Box - Standard install with 2nd php

Update 3.0.5.1 ran perfectly at the beginning of the month and server is solid and stable. Debian updates run / Clam AV update ran

But now update to 3.0.5.2 falls over after:

Creating backup of "/usr/local/ispconfig" directory...
Creating backup of "/etc" directory...

Almost immediately drops to shell prompt and just sits there.
Backups are created - and permissions are good...
/var/log/ispconfig_install.log has no entries after Mar 5th update

I have tried logging in as root / su / su - / sudo - nothing works.

Is there another log file / error trap file somewhere? Any ideas why this is happening?

Thanks in advance...

MaddinXx 29th March 2013 14:08

My problem is still not solved. After debugging, I found:

on line https://github.com/Rackster/ispconfi...in.inc.php#L54 I'm calling the method - and I get a FATAL Error, method not found.

It looks like it's called in a static scope (nginx_reverse_proxy_plugin::cert_helper()) - so I tried making the method static -> no success.

What could be wrong there? This is new since 3.0.5.2

Thanks for hints & help :)


All times are GMT +2. The time now is 10:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.