HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Ispconfig3 backup mode - issues (http://www.howtoforge.com/forums/showthread.php?t=61171)

Lionheart82 27th March 2013 14:35

Ispconfig3 backup mode - issues
 
Hello,

I was testing the new backup modes the last few weeks but it seems there are some issues i would like your opinion about :)

a)Backup mode as root
backups are created correctly in /var/backups but when tested i see no sql file dumb.

b) i switched to "web user as zip" in case it would help with the dbs but here is the thing. On websites backup tab i can see the file "web1_2013-03-24_22-32.zip" unfortunately i cannot restore it as it doesn't exist eg /var/backups/web1/ ( i only see the tar.gz file)

This is happening of course for all web sites.

I do have the zip - unzip libs also cron log shows no error...

Thank you for your time :)

System info:
php: 5.3.6
OS: centos 5.4
Web server: Apache
Ispconfig version 3: Latest

ressel 27th March 2013 16:57

Have you remembered to set all your databases to be linked to your websites?

Lionheart82 27th March 2013 17:14

Hmm this must be it then... i ll test it and i will inform you about the results so obvious !!!

RSInfotech 28th March 2013 22:13

.zip backup format issue
 
I've noticed a similar issue to Lionheart82 since upgrading to version 3.0.5.1 on my CentOS 5.9 server.

The tar.gz backups for both website content and databases work as expected once the databases have been linked to the websites under sites/databases. (As this is a new feature, it will need to be done for each database as already explained by Till)

But there is an issue when selecting to save website content in .zip format, the entry is recorded in the ISPConfig database correctly and shows up as successful on the websites backup tab, but no .zip file has been created in /var/backup/webxx.

The database backup is successful, although I think this is because the compression format for the database is always tar.gz regardless of your backup settings?

There seems to be an invalid command argument being passed to zip by the /usr/local/ispconfig/server/cron_daily.php script, running the shell scrip manually returns the following errors:

Quote:

zip error: Invalid command arguments (no such option: -)
zip error: Invalid command arguments (no such option: -)
PHP Warning: chown(): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 799
PHP Warning: chgrp(): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 800
PHP Warning: chmod(): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 801
zip error: Invalid command arguments (no such option: -)
zip error: Invalid command arguments (no such option: -)
PHP Warning: chown(): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 799
PHP Warning: chgrp(): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 800
PHP Warning: chmod(): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 801
finished.
The script then fails to change the permissions of the .zip file because the file does not exist.

This may be an issue affecting CentOS systems only as I can't seem to find anyone else complaining about the .zip format failure?

I'm still looking into the cause of this issue and will report back with anything else I find.

A big thank you to the developers for enabling us all to run such a wonderful system!


All times are GMT +2. The time now is 06:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.