HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   all sites point to default vhost (http://www.howtoforge.com/forums/showthread.php?t=61154)

xeriphism 26th March 2013 16:55

all sites point to default vhost
 
so last night I had all my websites up and operational but now after adding another domain pointing it correctly via the registrar at the box and adding it in ispconfig3 correctly every one of my sites points to the same vhost somehow.

such a frustrating problem because I know it's just something simple I'm missing somewhere and can fix it more permanently if I can just get my head around it, let me know if there's anything you want me to post,
I'm going to jump in and include the apachectl -S contents for your perusal...


[root@setareh client1]# apachectl -S
[Wed Mar 27 02:20:26 2013] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Wed Mar 27 02:20:26 2013] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Wed Mar 27 02:20:26 2013] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Wed Mar 27 02:20:26 2013] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Wed Mar 27 02:20:26 2013] [warn] NameVirtualHost 192.168.1.11:443 has no Virtua lHosts
VirtualHost configuration:
192.168.1.11:80 is a NameVirtualHost
default server phantasmsofthecabaretdun.com (/etc/httpd/conf/sites-enab led/900-phantasmsofthecabaretdun.com.vhost:7)
port 80 namevhost phantasmsofthecabaretdun.com (/etc/httpd/conf/sites-e nabled/900-phantasmsofthecabaretdun.com.vhost:7)
wild alias *.phantasmsofthecabaretdun.com
wildcard NameVirtualHosts and _default_ servers:
_default_:443 setareh.legacy.com (/etc/httpd/conf.d/ssl.conf:74)
_default_:8081 setareh.legacy.com (/etc/httpd/conf/sites-enabled/000-app s.vhost:10)
*:80 model2life.com (/etc/httpd/conf/sites-enabled/900-model2l ife.com.vhost:7)
*:80 winvestigate.com (/etc/httpd/conf/sites-enabled/900-winve stigate.com.vhost:7)
*:80 xeriphism.com (/etc/httpd/conf/sites-enabled/900-xeriphis m.com.vhost:9)
*:80 xeriphism.org (/etc/httpd/conf/sites-enabled/900-xeriphis m.org.vhost:7)
*:80 yourmumshole.com (/etc/httpd/conf/sites-enabled/900-yourm umshole.com.vhost:7)
*:8080 is a NameVirtualHost
default server setareh.legacy.com (/etc/httpd/conf/sites-enabled/000-is pconfig.vhost:10)
port 8080 namevhost setareh.legacy.com (/etc/httpd/conf/sites-enabled/0 00-ispconfig.vhost:10)
Syntax OK



check it out xeriphism.com, xeriphism.org, winvestigate.com, model2life.com they all point to phantasmsofthecabaretdun.com directory.

do you have any ideas Falko?

I've followed your tutorial to set up centos 6.3 box with apache2, courier and ispconfig3 tutorial to the letter and this seems to be something that is plaguing me, I need to work out where it is going wrong.

As far as I can understand it has something to do with either;
httpd.conf, sites-enabled/ vhost file somewhere or something like that
I'd really appreciate the help on this one!

Sincerely

XeriphisM

xeriphism 26th March 2013 18:56

aaaaaand fixed.
 
Actually I think I might have it sorted :

the ispconfig.conf and the httpd.conf files may have been clashing
also in the websites panel in ispconfig 3 setting each site to have an ipv4 address of * instead of the internal IP of the host machine.

wow now who feels stuuupid? ha


All times are GMT +2. The time now is 07:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.