HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   smtp sasl authentification failure, no explanation (http://www.howtoforge.com/forums/showthread.php?t=61115)

wck 24th March 2013 14:38

[Solved] smtp sasl authentication failure, no explanation
 
Hi,

Running ISPconfig 3 on Ubuntu Server 12.04 LTS (Perfect server guide Howto)
ISPconfig is up to date and I allowed it to reconfigure services.

I cannot send emails through my server. After trying to connect via Gmail, the logs show :

Code:

Mar 24 13:14:07 servername postfix/submission/smtpd[16901]: connect from mail-ie0-f178.google.com[209.85.223.178]
Mar 24 13:14:07 servername dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
Mar 24 13:14:09 servername postfix/submission/smtpd[16901]: warning: mail-ie0-f178.google.com[209.85.223.178]: SASL PLAIN authentication failed:
Mar 24 13:14:09 servername postfix/submission/smtpd[16901]: disconnect from mail-ie0-f178.google.com[209.85.223.178]

After a lot of Googling I see there is generally an explanation after "authentification failed: " but here, there is none.

Something else I've tried to check saslauthd :

Code:

testsaslauthd -u user@domain.com -p password -s smtp
0: NO "authentication failed"

Any help would be greatly appreciated.

wck 24th March 2013 17:47

Well... problem solved.

Most tutorials about this problem mention smtpd.conf (which didn't exist on my server...) but the authentication code is actually in /etc/dovecot/dovecot-sql.conf

In this file, the SQL query has an extra "AND disable%Ls = 'n'" compared to what's usually in smtpd.conf and I realized `disablesmtp` was set to 'y' for the account I was trying to use (in dbispconfig.mail_user).

So, two solutions :
- manually set `disablesmtp` to 'n'
or
- check "enable receiving" in the settings for this email mailbox (although I'm using it purely to send email, not receiving).

testsaslauthd still tells me "authentication failed"... but eh, it works.


All times are GMT +2. The time now is 13:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.