HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Joomla + PHP-FPM (http://www.howtoforge.com/forums/showthread.php?t=61083)

BigJens 22nd March 2013 15:09

Joomla + PHP-FPM
 
Hi Everybody,

as soon as I switch to PHP-FPM my Joomla Installations throw an error: The PHP temporary directory is not set.

According to the php.ini the upload_tmp_dir is empty. Any help here?

Regards
Jens

falko 23rd March 2013 19:55

Please set a value for upload_tmp_dir.

BigJens 23rd March 2013 20:09

Hmmhh I tried to set it in the Custom php.ini settings, but that didn't work. The upload_tmp_dir still showed up as 'non value'.

Where should I set the value then?

BigJens 26th March 2013 15:22

Nobody ?

ressel 26th March 2013 22:32

upload_tmp_dir = /var/www/clients/client1/web1/tmp

BigJens 27th March 2013 12:49

This is how my custom php.ini settings look now:
Code:

output_buffering = Off
upload_tmp_dir = /var/www/clients/client1/web134/tmp

And here is my PHP Information:

Code:

upload_tmp_dir        no value        no value
Looks like that doesn't work here, but I don't know why. Any other suggestions?
TIA
J.

ressel 27th March 2013 14:57

Quote:

Originally Posted by BigJens (Post 294802)
This is how my custom php.ini settings look now:
Code:

output_buffering = Off
upload_tmp_dir = /var/www/clients/client1/web134/tmp

And here is my PHP Information:

Code:

upload_tmp_dir        no value        no value
Looks like that doesn't work here, but I don't know why. Any other suggestions?
TIA
J.

Does phpinfo say following?

Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /var/www/conf/web134/php.ini

BigJens 27th March 2013 15:49

No it says:
Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /etc/php5/cgi/php.ini

How come? Hmmmhh.

falko 28th March 2013 17:41

PHP-FPM websites don't have their own php.ini. They use the default one, and custom settings are written in the pool file of the PHP-FPM process. Please check the appropriate pool file (e.g. in /etc/php5/fpm/pool.d/).

BigJens 28th March 2013 17:50

Okay, I understand. And custom php.ini settings via ISPconfig are ignored then?


All times are GMT +2. The time now is 12:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.