HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig, install issues and 1:1 NAT (http://www.howtoforge.com/forums/showthread.php?t=61025)

Alocaurd 19th March 2013 19:26

ISPConfig, install issues and 1:1 NAT
 
Hi,

I have installed ISPConfig in mulitserver setup as per the debian 6 server install instructions, and everything seemed to go without a hitch. I have since noticed a number of problems i cannot seem to sort out.

I'll start out with my layout.

I have an external IP block 199.XXX.XXX.163-174. These are setup as virtual IPs in PFsense, and forwarded with 1:1 nat to the appropriate machines.

Inside, i have ws1(192.168.2.10,199.XXX.XXX.163), ms1(192.168.2.20,199.XXX.XXX.164), ds1(192.168.2.30,no public IP), ns1(192.168.2.40,199.XXX.XXX.165), and ns2(192.168.2.41,199.XXX.XXX.166).

1st issue, following the guide verbatim doesnt install webmail as it is suggested. would i install this myself on ws1 or ms1?

2nd issue, much bigger, i cannot seem to use the DB server. right now, all sites are running off of the WS database. opening PHPMYADMIN from the control panel brings you to the WS database, not the DBserver database.

3rd, just as annoying, i cannot seem to assign external IPs directly to a client. All the guides say to use internal IP addresses, but everything else says that a hosting panel needs external addresses directly assigned. I also read i need to remove * from any site's ip address, and when i remove it from 000-default, when accessing any assigned IP, i get the error "you are trying access https on the standard http port". As a workaround, i had to assign the dedicated address as an alias webdomain

Let me know what logs or troubleshooting you would like to see.

till 20th March 2013 09:28

1) Install it on the webserevr and configure it to connect to the mailserver.
2) add the db server in the config.inc.php file of phpmyadmin.
3) You mix up bridged and NAT setups. You have to assign the internal IP addresses in your case and not the external IP addresses in a NAT setup. External IP's are only assigned when you use a bridegd setup and dont use NAT like you do.

Alocaurd 21st March 2013 03:49

Thanks for the quick reply!

1) I will give the webmail a go!
2) I will give the php a go as well! and report back on both!
3) I have a 1:1 NAT, and the machine does have an internal IP address, and all seems to work well. My question is just assigning other IPs directly to clients. Will i have to add another NIC and put it in the DMZ, or is there another way to do that?


Thanks!

till 21st March 2013 09:39

3) If you have muliple external IP's, then you have to add the same number of internal IP's on your server (network card) and in ispconfig and configure your router to route the correct external Ip to the corresponding internal IP.

Alocaurd 21st March 2013 14:42

Thanks Till,

I figured that would work, i just didnt want the client to see 192.168.2.13 for their address on the panel instead of 199.XXX.XXX.172 etc. is there any way of changing this? Or is this the only way behind NAT. Nota huge issue, but would be nice nonetheless.

Thanks


All times are GMT +2. The time now is 16:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.