HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   problems with su-php and multiple wesite for the same client (http://www.howtoforge.com/forums/showthread.php?t=61010)

tchouvince 18th March 2013 16:57

problems with su-php and multiple wesite for the same client
 
Hello all,

I have a problem with mod su-php:
When I create multiple website for a same client, I have that in my directory:

/var/www/clients/client1/web1
/var/www/clients/client1/web2
etc...

I want to use mod su-php for all websites for all clients.

For the first website, no problem.
For the second website, I have an error 500.
In logs, I have that:
SoftException in Application.cpp:555: Directory /var/www/clients/client1 is not owned by web2


If I change owner for example chown -R web2:client1, the second website work but the first website no.

What can I do for it work with owner web1:client1 for the first webiste, client1:web2 for the second site etc....

Thanks for advance et excuse me for my very bad english.

almere 18th March 2013 20:40

Quote:

Originally Posted by tchouvince (Post 294180)
Hello all,

I have a problem with mod su-php:
When I create multiple website for a same client, I have that in my directory:

/var/www/clients/client1/web1
/var/www/clients/client1/web2
etc...

I want to use mod su-php for all websites for all clients.

For the first website, no problem.
For the second website, I have an error 500.
In logs, I have that:
SoftException in Application.cpp:555: Directory /var/www/clients/client1 is not owned by web2


If I change owner for example chown -R web2:client1, the second website work but the first website no.

What can I do for it work with owner web1:client1 for the first webiste, client1:web2 for the second site etc....

Thanks for advance et excuse me for my very bad english.

You’ve got the wrong permissions set on one or more folders.
Please, change permissions of your index file to 755 (because now you have 777, I guess).
You can try this for each site (in your case for web1 and web2):

If you care about your security:
find /var/www/clients/client1/web1/web/* -type f -exec chmod 644 {} \;
find /var/www/clients/client1/web1/web/* -type d -exec chmod 755 {} \;
find /var/www/clients/client1/web2/web/* -type f -exec chmod 644 {} \;
find /var/www/clients/client1/web2/web/* -type d -exec chmod 755 {} \;

If you do not care about your security, or just lazzzzzzzy:
chmod -R 755 /var/www/clients/client1/web1/web/
chmod -R 755 /var/www/clients/client1/web2/web/

till 19th March 2013 09:18

Just as a sidenote, dont use suphp these days. It is too slow. A better alternative s to use php-fcgi or php-fpm and enable the suexec checkbox in the site settings, this is much faster then suphp and will run the php scripts under the website user.

tchouvince 19th March 2013 12:02

Quote:

Originally Posted by almere (Post 294189)
You’ve got the wrong permissions set on one or more folders.
Please, change permissions of your index file to 755 (because now you have 777, I guess).
You can try this for each site (in your case for web1 and web2):

If you care about your security:
find /var/www/clients/client1/web1/web/* -type f -exec chmod 644 {} \;
find /var/www/clients/client1/web1/web/* -type d -exec chmod 755 {} \;
find /var/www/clients/client1/web2/web/* -type f -exec chmod 644 {} \;
find /var/www/clients/client1/web2/web/* -type d -exec chmod 755 {} \;

If you do not care about your security, or just lazzzzzzzy:
chmod -R 755 /var/www/clients/client1/web1/web/
chmod -R 755 /var/www/clients/client1/web2/web/

Thanks you very much.
Now it's works.
I had also change owner of client's directory (for example /var/www/clients/client1):
the client's directories seems to be root.

tchouvince 19th March 2013 12:03

Thanks you for this post.
I will to see that.

Quote:

Originally Posted by till (Post 294229)
Just as a sidenote, dont use suphp these days. It is too slow. A better alternative s to use php-fcgi or php-fpm and enable the suexec checkbox in the site settings, this is much faster then suphp and will run the php scripts under the website user.



All times are GMT +2. The time now is 20:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.