HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Strange lines in /etc/fstab (http://www.howtoforge.com/forums/showthread.php?t=60974)

lollollollol 16th March 2013 14:51

Strange lines in /etc/fstab
 
Ispconfig ISPConfig Version: 3.0.5.1
Debian Wheezy

Hi, I just discover 4 strange lines in my fstab:

Code:

cat /etc/fstab
...
/var/log/ispconfig/httpd/domain1.tld /var/www/clients/client1/web57/log    none    bind,nobootwait    0 0
/var/log/ispconfig/httpd/domain2.tld /var/www/clients/client0/web61/log    none    bind,nobootwait    0 0
/var/log/ispconfig/httpd/domain3.tld /var/www/clients/client0/web77/log    none    bind,nobootwait    0 0
/var/log/ispconfig/httpd/domain4.tld /var/www/clients/client0/web78/log    none    bind,nobootwait    0 0

Same taht in this thread:
http://www.howtoforge.com/forums/showthread.php?t=60864
It's in this bug repport too:
http://bugtracker.ispconfig.org/inde...s&task_id=2541

My questions:
- Is it normal to have this lines ?
- What is their utility ?
- Can I umount and remove it safely ?

Thank you in advance.
Laurent

florian030 16th March 2013 17:11

Quote:

My questions:
- Is it normal to have this lines ?
yes

Quote:

- What is their utility ?
Shell-Users can access their logfiles.

Quote:

- Can I umount and remove it safely ?
You can remove the bind-mounts. But there is no really reason. Beside this, i didnīt like the solution, too. See http://www.howtoforge.com/forums/showthread.php?t=60237

Not sure why, but on my servers neither the mounts are unmounted during shutdown nore mounted automaticly after reboot.

Thank you in advance.
Laurent[/QUOTE]

lollollollol 17th March 2013 10:57

Hi florian030,

Thanks for the answer, I didn't realize the interest for shell users.
I was waiting for an answer before rebooting, so thanks! :)

Laurent.

till 18th March 2013 16:23

Quote:

Not sure why, but on my servers neither the mounts are unmounted during shutdown nore mounted automaticly after reboot.
Then there must be something wrong with your OS setup. All mount points defined in /etc/fstab are mounted at boot time. I tested it here and it works finr on my servers.

florian030 19th March 2013 18:20

Maybe.... my web-dir is on a drbd-volume with ocfs2 as the filesystem and the log-dirs are on local ext3-partition.

I think, the entries in /etc/fstab are wrong, since the mount could not be done duringt startup. Itīs only possible after the drbd/ocfs2-mounts are done.

till 20th March 2013 09:15

The entries in fstab are correct. If you use filesystems which does not get loaded at a later time, you can add "mount -a" command in a rc file like rc.local which is executed after your network filesystem is loaded to mount all mountpoints that could not be loaded at boot time.

andypl 21st March 2013 13:50

There is one error in the mounting when we remove the page entry in /etc/fstab gone but still mount is active until you restart the server.

ADM 28th March 2013 20:22

I have same issue.

I don't like that ispconfig edit my /etc/fstab, please tell me how to disable this feature.

Also my clients does not have SSH access, why I should have this entry in /etc/fstab?

There is also a big issue with this settings

If you try to make a new dir inside the web folder you get Permission Denied even as root user!

try this:
Code:

cd /home/www/clients/client1/web1
mkdir testdir
touch testfile

ispconfig is the stata of the art for hosting but i really dislike this issue introduced by 3.0.5.1

I don't want to go back to 3.0.4.x but please give me a solution to fully disable this feature.

Thanks very much.

ADM 2nd April 2013 15:56

Is it working as intended that root user can't make dirs inside /home/www/clients/clientN/webN/ dir?

Or it is a side effect of this /etc/fstab manipulation?


All times are GMT +2. The time now is 16:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.