HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Feature Requests (http://www.howtoforge.com/forums/forumdisplay.php?f=31)
-   -   Apache httpd 2.4 support (http://www.howtoforge.com/forums/showthread.php?t=60953)

iDen 14th March 2013 17:44

Apache httpd 2.4 support
 
Any plans regarding support of httpd 2.4 in ISPconfig v 3.0.5.x ?

till 14th March 2013 21:06

Is there already a Linux distribution that ships with apache 2.4 as default?

iDen 14th March 2013 21:13

There is distribution with 2.4 rpm compiled by me with provided spec.
Syntax differs from 2.2 ...
Fedora 18 has.
RHELv7 is announced to be available this fall, it will have.
So it was just question.
Quote:

Originally Posted by till (Post 293979)
Is there already a Linux distribution that ships with apache 2.4 as default?


till 25th March 2013 17:10

We will add support for apache 2.4 off course, but I can not give you a date when it gets finished.

SSullivan 22nd August 2013 08:52

Hi Till,

What happens if I install this, make the required changes (such as AUTH is different) and then later upgrade ISPconfig? Does ISPConfig re-install Apache 2.2?

till 22nd August 2013 09:52

ISPConfig odes not install any software. If you change sourcecode of a software and install a update of that sotware, the update will overwrite your custom changes.

iDen 2nd January 2014 13:22

Wow wow !!!

Just saw in Roadmap that you have added plans to support Apache 2.4 in next minor release.

Does it mean that ISPconfig will support at least new mod_proxy_fcgi for better PHP-FPM integration?
Help old FastCGI die :)

Of course we understand that such additions will make release available not so soon.

Quote:

Originally Posted by till (Post 294676)
We will add support for apache 2.4 off course, but I can not give you a date when it gets finished.


iDen 3rd January 2014 08:59

there is bug with apache 2.4.x
mod_proxy/mod_proxy_fcgi right now doesn't support unix sockets to connect with php-fpm, only tcp.

https://issues.apache.org/bugzilla/s...g.cgi?id=54101
http://wiki.apache.org/httpd/PHP-FPM

till 3rd January 2014 09:01

For 3.0.5.4 we plan to support the same features that are available for apache 2.2 in ISPConfg, so basically we will add code to support the new config syntax. mod_proxy_fcgi is not on our roadmap yet. Feel free to make a feature request for it in the bugtracker, in case that there is no such requestyet (havent checked it).

demofreak 29th January 2014 23:58

Is it possible to "cherry-pick" the already completed task into an existing 3.0.5.3 installation?

I had to upgrade an OpenSUSE 12.3 box, and in the next distro release 13.1 there's no Apache 2.2 available anymore.

Thanks.


All times are GMT +2. The time now is 12:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.