HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   installing isp config to opensuse 12.3 (http://www.howtoforge.com/forums/showthread.php?t=60945)

bullet 13th March 2013 22:28

installing isp config to opensuse 12.3
 
I just installed isp config to opensuse 12.3 using the perferct server example for 12.2 x64

Had a few errors that I got through with out an issue..
but during the install of isp config there was an error as listed at the bottom:

When I went to the control panel it didn't function. I took a look at /etc/groups and added:

wwwrun which was missing

ispapps:x:5002:wwwrun
ispconfig:x:5003:wwwrun

This got the panel working. I'm wondering if there were any other users needed to be added to groups?

Also, pure-ftpd fails to start, I don't get much out of the logs other then this:


2013-03-13T16:43:38.108183-04:00 foxconn systemd[1]: Starting Pure-FTPd FTP server...
2013-03-13T16:43:38.115905-04:00 foxconn systemd[1]: Started Pure-FTPd FTP server.
2013-03-13T16:43:38.120166-04:00 foxconn pure-config.pl[1998]: Running: /usr/sbin/pure-ftpd -A -c10 -B -C3 -z -D -E -fftp -H -I15 -lmysql:/etc/pure-ftpd/db/mysql.conf -L2000:8 -m4 -s -U133:022 -u40 -x -r -i -k99 -G -Z -Y1

Any ideas?



Configuring Jailkit
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
groupmod: unrecognized option '--add-user'
Usage: groupmod [options] GROUP

Options:
-g, --gid GID change the group ID to GID
-h, --help display this help message and exit
-n, --new-name NEW_GROUP change the name to NEW_GROUP
-o, --non-unique allow to use a duplicate (non-unique) GID
-p, --password PASSWORD change the password to this (encrypted)
PASSWORD
-R, --root CHROOT_DIR directory to chroot into

Configuring Getmail
Configuring Pureftpd
Configuring BIND
Configuring Apache
Configuring Vlogger
Configuring Apps vhost
Configuring Bastille Firewall
Configuring Fail2ban
Installing ISPConfig
ISPConfig Port [8080]:

bullet 13th March 2013 23:43

I disabled and enabled FTP in the control panel and pure-ftp is started.

Seems to be working ok now, I'll reboot and see if it comes up on startup.

Yes, it's staying up and working.


Correction, it runs for a few minutes then dies...



I added 2 'websites' and I get the same issue as I did with opensuse 12.2, squrrel mail and phpmyadmin stop working. The php scripts don't execute in the browser they just download instead.

Also, same thing with the virtual hosts, no matter where or what I use to access them they all go to the same 'website'. Using dns names of course.

till 14th March 2013 09:22

Just a question, why dont you use one of the distributions that are recommended for ispconfig like Debian or Ubuntu server? The setup in these distributions is much easier then opensuse and they work more stable.

bullet 14th March 2013 10:31

I've been using opensuse for years and manage numerous servers based on them. I just wanted to stick to something I know.

But, I got sick of trying and did the ubuntu 12.10 perfect server and it's all working 100%. Had some issues with starting php-5.3.18, but I see I'm not the only one.

I'm wondering now if I should try the LTS version just to get long term support on the distro. How do these two compare?

TheBigS 17th April 2013 09:24

I had the same problems with opensuse 12.3 and pure-ftp. Google shows me the the following thread and there was a solution. if pure-ftpd is not starting with opensuse 12.3, you have to chanage the pure-ftpd.conf like this:

Code:

# Fork in background

Daemonize                  no #yes is standard

it seems it is a bug.

here is the source of my information. at the moment it seems working.


All times are GMT +2. The time now is 13:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.