HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   500 error (http://www.howtoforge.com/forums/showthread.php?t=60889)

codingideas 9th March 2013 22:28

500 error
 
Hello,

It seems that nginx reports 500 errors whenever there is a php error. I have set in the Custom php.ini settings for that site and when I look at phpinfo(); I dont see that being over ridden and I keep getting errors.

What do you think could be happening?

Quote:

2013/03/09 23:09:47 [error] 32230#0: *2761 readv() failed (104: Connection reset by peer) while reading upstream, client: ----, server: ----, request: "POST /wp-admin/admin.php?import=woocommerce_csv&step=2&merge=1 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9072", host: "------", referrer: "-----/wp-admin/admin.php?import=woocommerce_csv&step=1&merge=1&_w pnonce=2dc8bdc9a9"

Custom php.ini settings

Quote:

display_errors = on
register_globals = Off
allow_url_fopen = Off
allow_url_include = Off
post_max_size = 256M
upload_max_filesize = 256M
max_execution_time = 600
max_input_time = 600
memory_limit = 256M
mail.add_x_header = Yes

nginx Directives

Quote:

client_max_body_size 256M;
fastcgi_send_timeout 600s;
fastcgi_read_timeout 600s;

location / {
try_files $uri $uri/ /index.php?$args;
}
# Add trailing slash to */wp-admin requests.
rewrite /wp-admin$ $scheme://$host$uri/ permanent;
location ~* \.(jpg|jpeg|png|gif|css|js|ico)$ {
expires max;
log_not_found off;
}

Here is my phpinfo page. http://goo.gl/DA47X - as you can see I put display_errors = on but in the phpinfo - display_errors = off. :(

falko 12th March 2013 18:27

Disable XCache and try again.


All times are GMT +2. The time now is 22:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.