HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Postfix/SMTP Beginner Problem (http://www.howtoforge.com/forums/showthread.php?t=60878)

rannday 9th March 2013 06:16

Postfix/SMTP Beginner Problem
 
5 Attachment(s)
I'm able to send/receive emails locally, but not externally. All the required ports are open on my home router. Attached are my current firewall rules, main.cf, mail.log - tail end of it, and my godaddy zone file. My server was set up following

http://www.howtoforge.com/perfect-se...nx-ispconfig-3

Everything went smoothly, but I just don't completely understand what I'm doing wrong with postfix and/or smtp. I'm unable to telnet outside of my LAN, and when I went here

http://mxtoolbox.com/

and ran the blacklist check, two websites have me blacklisted, even though I've never had the website going until now. The SMTP check failed as well.

I added the results of lsof -i -n -P. I have some netstat runs as well, if need be. I could also install nmap and run that. It would probably be best to run all of these from a different computer, though. I'll also run them on my router. Will take a minute.

rannday 9th March 2013 08:14

More Information
 
3 Attachment(s)
I ran some more scans. Two were intensive zenmap scans from another host to my server and gateway. The other is a nmap scan through a proxy to my IP.

I did a scan from http://mxtoolbox.com and the results are much different.

21 Open
22 Open
25 smtp Thread was being aborted.
53 Open
80 http Thread was being aborted.
110 Open
143 Open
443 https No connection could be made because the target machine actively refused it xx.xx.xx.xx:443

So perhaps it's a firewall issue. I'll try opening those up and see what happens.

rannday 9th March 2013 09:08

Think I Got It Working
 
Not sure which setting it was. First I tried
Code:

iptables -P OUTPUT ACCEPT
And tried and thought it didn't work. I then looked up the relay for Cox Communications, which is smtp.east.cox.net, added that to my main.cf. There weren't any errors in my mail.log so I checked the email I sent it it to and had two test emails in there. Now I'll try to receive.


All times are GMT +2. The time now is 22:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.