HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Dovecot failed! after 3.0.5.1 upgrade (http://www.howtoforge.com/forums/showthread.php?t=60863)

BrainyForge 8th March 2013 10:52

SOLVED-Dovecot failed! after 3.0.5.1 upgrade
 
Hi,:)
after upgrading to v. 3.0.5.1, showed me the following error:
Code:

Fatal: listen(::, 143) failed: Address already in use
Restarting IMAP/POP3 mail server: dovecot failed!

I checked the port 143 is occupied but not
Code:

  netstat -avp | grep "imap\|143"
  netstat: no support for `AF IPX' on this system.
  netstat: no support for `AF AX25' on this system.
  netstat: no support for `AF X25' on this system.
  netstat: no support for `AF NETROM' on this system

Tips?
The machine is a VPS with Debian 6 installed following the guidance Installing A Web, Email & MySQL Database Cluster On Debian 6.0 With ISPConfig 3

Thank you for your attention

BrainyForge 8th March 2013 16:07

:( Please a little help :)

BrainyForge 9th March 2013 11:27

Solved
 
The problem is solved ritornado the previous version, thanks to backup!:D

BrainyForge 11th March 2013 12:12

What would you recommend for the update to wait for a new version? I have only had this problem?
is a problem of ports?

till 11th March 2013 12:39

There are no known problems with the 3.0.5.1 update and dovecot,so it seems as you install is the only one affected which makes it very unlikely that there is a issue in ispconfig. Pleasecheck with:

netstat -tap | grep imap

which program is listening on the imap port.

BrainyForge 21st March 2013 18:23

I do not know why, but every time aggiornavo ISPConfig version of the problem recurs, I solved this way:

I added the file dovecot.conf
listen = *

Code:

nano /etc/dovecot/dovecot.conf

Code:

[...]
listen = *, [::]
listen = *
[...]

After saving

Code:

/etc/init.d/dovecot start
And now it works.:)
I hope to good use.

accdl 23rd March 2013 11:38

Thanks, very useful

Hairy 23rd March 2013 23:42

Does dovecot get updated during the ispconfig 3.0.5.1 update?

falko 28th March 2013 16:46

ISPConfig doesn't update any software, but you can choose to reconfigure services during the ISPConfig update. Choose no if you don't want ISPConfig to change your current configuration.

BrainyForge 29th March 2013 18:12

I confirm that for Update on the ISPConfig 3.0.5.2 the problem persists.
Is solved by adding the line.


All times are GMT +2. The time now is 02:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.