HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   BIND won't respond to queries (http://www.howtoforge.com/forums/showthread.php?t=60861)

mzandstra 8th March 2013 03:29

BIND won't respond to queries
 
Hello,

I'm having some trouble getting my nameserver up and running. The domain I'm using is hadoukenlabs.com, and I registered the nameserver as ns1.hadoukenlabs.com. I followed a tutorial to install and configure bind, but I keep getting SERVFAIL.

I have been making a few changes here and there, but nothing seems to work. Port 53 is forwarded properly but I can't seem to even ping the nameserver from another computer. cmd > ping ns1.hadoukenlabs.com (from a separate windows machine) doesn't even resolve the nameserver ip, although DNS lookup tools find the IP just fine. Any ideas?

ns1.hadoukenlabs.com
LAN IP: 192.168.0.61
WAN IP: 64.251.150.213
OS: Debian 6.0.6

/etc/resolv.conf
Code:

domain hadoukenlabs.com
search hadoukenlabs.com
nameserver 64.251.150.213

/etc/bind/named.conf
Code:

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
include "/etc/bind/ns1.hadoukenlabs.com.rndc.key";

/etc/bind/named.conf.local
Code:

zone "hadoukenlabs.com" {
        type master;
        file "hadoukenlabs.com.db";
};

zone "0.168.192.in-addr.arpa" {
        type master;
        file "192.168.0.rev";
};

/etc/bind/named.conf.options
Code:

options {
        directory "/var/cache/bind";

        auth-nxdomain no;    # conform to RFC1035
        listen-on port 53 { any; };
        listen-on-v6 port 53 { any; };
        allow-query { any; };
        recursion yes;
};

/etc/bind/named.conf.default-zones
Code:

zone "." {
        type hint;
        file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
        type master;
        file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
        type master;
        file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
        type master;
        file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
        type master;
        file "/etc/bind/db.255";
};

/etc/bind/hadoukenlabs.com.db
Code:

@      IN      SOA    ns1.hadoukenlabs.com. root.hadoukenlabs.com. (
                    2013030601        ; Serial
                        604800        ; Refresh
                          86400        ; Retry
                        2419200        ; Expire
                        604800 )      ; Default TTL

hadoukenlabs.com        IN      NS      ns1.hadoukenlabs.com.

www    IN      A      64.251.150.213
ns1    IN      A      64.251.150.213

/etc/bind/192.168.0.rev
Code:

@      IN      SOA    hadoukenlabs.com. root.hadoukenlabs.com. (
                    2013030601        ; Serial
                        604800        ; Refresh
                          86400        ; Retry
                        2419200        ; Expire
                        604800 )      ; Default TTL

        IN      NS      ns1.hadoukenlabs.com.

10      IN      PTR    www.hadoukenlabs.com.
20      IN      PTR    ns1.hadoukenlabs.com.


mzandstra 18th March 2013 23:40

*Shameless bump*

Hasn't anyone on this forum used bind before?

falko 23rd March 2013 19:07

You've forgotten a dot here:

Code:

hadoukenlabs.com.        IN      NS      ns1.hadoukenlabs.com.
If this still doesn't help, check your logs (e.g. /var/log/syslog).

mzandstra 23rd March 2013 22:52

Thanks!
 
Thanks so much for pointing me to the syslog file. I had to fix the dot, some permissions in /etc/bind/ and also use absolute paths to the .db and .rev files. Thank-you thank-you thank-you!


All times are GMT +2. The time now is 21:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.