HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Permissions Issue (http://www.howtoforge.com/forums/showthread.php?t=60767)

spikes 2nd March 2013 02:27

Permissions Issue
 
Hi

ispconfig: 3.0.5.1
webserver: apache
linux: debian sqeeze

I have recently upgraded to 3.0.5.1 and it seems I have a permissions problem. I have previously made a folder var/www/clients/client0/web1/file/ with sub-folders to hide them from normal web access. After upgrade it seems the script cannot access the folder any more

Cache Directory "/var/www/clients/client0/web1/file/cache" not writeable

I have checked permissions of folder

drwxr-xr-x 15 web1 client0 4096 Mar 2 10:57 file

It looks like the script should still be able to access the folder but everything has stopped working.

falko 2nd March 2013 12:21

Try

Code:

chattr -i /var/www/clients/client0/web1/file

spikes 2nd March 2013 13:02

I ran that but it does not seem to have made a difference, the condition is still the same.

spikes 3rd March 2013 10:42

I am a bit stuck and need some more help. What else can I try? Thanks in advance.

till 4th March 2013 12:30

run:

chattr -i /var/www/clients/client0/web1

File locations like /var/www/clients/client0/web1/file are not supported anymore when you have folder protection enabled in ispconfig for security reasons. If you want to store files outside of the web dir, then use the new private directory:

/var/www/clients/client0/web1/private


All times are GMT +2. The time now is 16:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.