HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Multiserver Setup: Questions (http://www.howtoforge.com/forums/showthread.php?t=60732)

ZeroEnna 28th February 2013 10:52

Multiserver Setup: Questions
 
Hello everyone,

Because updates have arrived lately, I have some questions before I perform the update, alternatively for the next updates to come:

What is the best practice? Master first, Slaves last?
What about "reconfigure permissions"? Should I do that? If so, on which machines?

Now, on one of the Multiservers I set up, I get error message since this night.
It says "Access denied for user 'ispcsrv6'@'h2087386.stratoserver.net'". I assume this is a result of mismatching "reconfigure permissions", as I did it on one of the servers, but not on the other one (I think the master, I said "no", but I'm not sure). How to fix that?

Thank you in advance.

Kind Regards


Sascha Schröder

till 28th February 2013 10:53

http://www.howtoforge.com/forums/showthread.php?t=60710

ZeroEnna 28th February 2013 11:05

Well, thank you, now, I have another problem.
I joined a server to a multiserver environment using the Multiserver Tutorial here on HowToForge.
I use a vServer from Netcup with a modified hostname and changed rDNS settings ( I did a clean reinstall with the new values, so no old hostname was used in any way, plus I did every step exactly as in the "Perfect Server" Tutorial).
However, when I run the cronjob on the slave, it tries to connect with

'ispcsrv4'@'v22013021556811042.yourvserver.net'
instead of
'ispcsrv4'@'merkur.webservices-schroeder.de'

How can I change this?

Kind Regards

Sascha Schröder

till 28th February 2013 11:14

ensure that yiu have the correct hostname in the /etc/hosts file on master and slave before you install ispconfig on the slave. If you installed it already, then most likely the permissions (hostname) in the master DB are wrong now and you will have to fix them for the ispcsrv4 manually with phpmyadmin. Also the master server hostname can be wrong in the server config.inc.php file on the slave.

ZeroEnna 28th February 2013 11:18

Hello till,

so, I checked, /etc/hosts, the hostname for the respective server is correct, the master has the right hostname in it, and so does the slave.
I just don't understand where the MySQL client on the slave gets the wrong hostname from. I never even mentioned it anywhere during the system setup and the ISPConfig setup respectively.

Kind Regards

Sascha Schröder

EDIT: Setting it to the root user does it, but this can not be a final solution.

ZeroEnna 1st March 2013 12:29

Reading the instructions is good, but reading them accurately is a lot better as I have found out yesterday evening.
Now that all IPs are entered in /etc/hosts on every server, everything works perfectly!

Thank you very much!

Kind Regards

Zero


All times are GMT +2. The time now is 09:12.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.