HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Latest Update 3.0.5.1 breaks webmail (http://www.howtoforge.com/forums/showthread.php?t=60719)

jcombs_31 27th February 2013 16:09

Latest Update 3.0.5.1 breaks webmail
 
I'm getting an internal server error and getting this in my logs.

SoftException in Application.cpp:221: File "/var/www/webmail/index.php" is not in document root of Vhost "/var/www/ispconfig/"

Anyone else seen this after the latest update? I'm using roundcube as per http://www.howtoforge.com/how-to-ins...debian-squeeze

till 27th February 2013 16:27

You can not access other applications trough the ispconfig vhost on port 8080 with the latest ispconfig version. The ispconfig vhost was never made for that. If you want to access a external application by http, create e.g. a separate vhost for it or use the ispconfig apps vhost which has been made for that.

Inspi 27th February 2013 18:12

Ich habe das Problem auch gehabt und ersteinmal so gelöst:

Quote:

a2dismod suphp
Damit läuft Webmail ersteinmal bis ich es als eigene Webseite angelegt habe.
Vielleicht sollte man das Howto zum Installieren von Roundcube ebenfalls anpassen.

jcombs_31 27th February 2013 18:12

Thanks, I changed to use the apps vhost and all it working, but had to add the SSL bindings to the vhost.

beyerservice 2nd March 2013 00:26

for someone found this after searching google for that error:

Solution:

Add red-Lines if not in your roundcube.conf file.
[...]
<Directory /var/www/roundcubemail>
Options FollowSymLinks

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .
php_admin_value upload_tmp_dir /var/www/roundcubemail/temp
php_admin_value open_basedir /var/www/roundcubemail:/etc/hostname:/etc/mailname
php_flag register_globals off
</IfModule>



sorry for crosspost this.


All times are GMT +2. The time now is 11:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.