HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPConfig 3.0.5.1 released (http://www.howtoforge.com/forums/showthread.php?t=60716)

till 27th February 2013 14:08

ISPConfig 3.0.5.1 released
 
ISPConfig 3.0.5.1 is available for download. This release is a bugfix release for ISPConfig 3.0.5.

For a detailed list of changes, please see the changelog section below.

================================================== ===
*** New! The ISPConfig 3 manual for ISPConfig 3.0.5 is now available! ***

Version 1.4 for ISPConfig >= 3.0.5 (Date: 02/22/2013)
Author: Falko Timme <ft@falkotimme.com>

373 pages

The manual can be downloaded from these two links:

http://www.ispconfig.org/ispconfig-3...nfig-3-manual/
http://www.howtoforge.com/download-t...onfig-3-manual
================================================== ===

-----------------------------------------------------
- Download
-----------------------------------------------------

The software can be downloaded here:

http://prdownloads.sourceforge.net/i...3.0.5.1.tar.gz

------------------------------------
- Changelog
------------------------------------

http://bugtracker.ispconfig.org/inde...&status[]=

--------------------------------------
- Known Issues:
--------------------------------------

Please take a look at the bugtracker:

http://bugtracker.ispconfig.org

--------------------------------------
- BUG Reporting
--------------------------------------

Please report bugs to the ISPConfig bugtracking system:

http://bugtracker.ispconfig.org

----------------------------------------
- Supported Linux Distributions
----------------------------------------

- Debian Etch (4.0) - Squeeze (6.0) and Debian testing
- Ubuntu 7.10 - 12.10
- OpenSuSE 11 - 12.2
- CentOS 5.2 - 6.3
- Fedora 9 - 15

-----------------------------------------
- Installation
-----------------------------------------

The installation instructions for ISPConfig can be found here:

http://www.ispconfig.org/ispconfig-3/documentation/

or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

------------------------------------------
- Update
------------------------------------------

To update existing ISPConfig 3 installations, run this command on the shell:

ispconfig_update.sh

Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

Detailed instructions for making a backup before you update can be found here:

http://www.faqforge.com/linux/contro...e-ispconfig-3/

If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

-------------------------------------------
- Manual update instructions
-------------------------------------------

Code:

cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php


edge 27th February 2013 14:10

Updated my Debian servers with no problem (as usual for me)

Thank you.

Petr 27th February 2013 14:37

Hello,
updating all servers with no problem. thanks.
but one question:
- on single server instalation ispc 3 working APS installer correct.
- on multiserver instalation i have one problem:
APS installation stay on status "installation_task" , but cms is installed correct.
this status is have one problem - unexist button delete and repair APS.
(I am installed APS on slave server always )

I use Debian 6 , same problem is in 3.0.5 and 3.0.5.1 too.

till 27th February 2013 14:39

Quote:

- on multiserver instalation i have one problem:
APS installation stay on status "installation_task" , but cms is installed correct.
this status is have one problem - unexist button delete and repair APS.
(I am installed APS on slave server always )
Did you choose yes for "update permissions in master databse" during update of the slave? If not, the slave cant update the status when it installs a aps package.

Petr 27th February 2013 15:05

You're right!
I am update ISPC manually with "update permition -yes", and works for me now.
my mistake, sorry.

radim_h 27th February 2013 22:38

shell users not deleted when website deleted
 
Hello,
In new version 3.5.1. When i created the site and then delete, shell users are not deleted (i even tried to delete system users, actually deleted all users and pages from system)

but in /etc/passwd then still stays records as

web2:x:5004:5006::/var/www/clients/client1/web2:/bin/false
ispconfigend:x:20000:20000::/usr/local/ispconfig:/bin/sh
web3:x:10003:5005::/var/www/clients/client0/web3:/bin/false
web4:x:10004:5005::/var/www/clients/client0/web4:/bin/false
web5:x:10005:10005::/var/www/clients/client2/web5:/bin/false
web6:x:20001:5006::/var/www/clients/client1/web6:/bin/false

I tried with both settings "Connect Linux userid to webid" On/Off
when "Add web users to -sshusers- group" is enabled

till 28th February 2013 09:23

@radim_h: Thanks for the bugreport. I've added it to the bugtracker.

Petr 28th February 2013 11:03

I still have a problem with APS installation:
on slave #2 APS can be installed, but uninstall fails (status ends at apps_removed).
on slave #1 APS does not installed (status ends at instaltion_task and the installation will not complete).
I attach a test on slave #2:

Code:

2013-02-28 08:56        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:56        slave1.server.tld        Debug        There is already an instance of server.php running. Exiting.       
2013-02-28 08:55        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:55        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:55        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:55        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:55        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:55        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:55        slave1.server.tld        Debug        There is already an instance of server.php running. Exiting.       
2013-02-28 08:54        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:54        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:54        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:54        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:54        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:54        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...
2013-02-28 08:53        slave1.server.tld        Debug        There is already a lockfile set. Waiting another 10 seconds...       
2013-02-28 08:52        slave1.server.tld        Debug        Running installHandler       
2013-02-28 08:52        slave1.server.tld        Debug        Starting APS install       
2013-02-28 08:52        slave1.server.tld        Debug        Calling function 'install' from plugin 'aps_plugin' raised by event 'aps_instance_update'.       
2013-02-28 08:52        slave1.server.tld        Debug        Replicated from master: REPLACE INTO aps_instances (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`customer_id`,`package_id`,`instance_status`) VALUES ('11','108','107','riud','riud','','13','106','47','1')       
2013-02-28 08:52        slave1.server.tld        Debug        Processed datalog_id 11729       
2013-02-28 08:52        slave1.server.tld        Debug        Replicated from master: REPLACE INTO aps_instances_settings (`id`,`server_id`,`instance_id`,`name`,`value`) VALUES ('155','13','11','main_database_login','c106aps6')       
2013-02-28 08:52        slave1.server.tld        Debug        Processed datalog_id 11728

I remove virtualhost with aps:

Code:

2013-02-28 09:19        slave1.server.tld        Debug        Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock       
2013-02-28 09:18        slave1.server.tld        Debug        Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock       
2013-02-28 09:18        slave1.server.tld        Debug        Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock       
2013-02-28 09:17        slave1.server.tld        Debug        Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock       
2013-02-28 09:17        slave1.server.tld        Debug        Calling function 'restartHttpd' from module 'web_module'.

look ok..

so...
Code:

slave1:~# /usr/local/ispconfig/server/server.sh
28.02.2013-09:39 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
28.02.2013-09:39 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

does anyone have an idea what to do to try for the correction?

debian 6, last update, kernel without modifications.

thx Petr

till 28th February 2013 11:37

Is this a multiserver setup or a mirror setup?

Petr 28th February 2013 11:58

Multiserver 1x master/mail , 3x slave/web , 2xslave/dns


All times are GMT +2. The time now is 20:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.