HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Upgrading a Multi Server Setup (http://www.howtoforge.com/forums/showthread.php?t=60710)

atjensen11 27th February 2013 06:32

Upgrading a Multi Server Setup
 
Hello,

I have a multi server setup which was installed and configured using the following How To as a template.

http://www.howtoforge.com/multiserve...th-ispconfig-3

There were a few minor modifications made to the setup to suite my needs.

I received notice today that ISPConfig version 3.0.5 is now released. This will be the first update I have had to apply to my relatively new multi server setup.

Do I need to apply the update to all servers? Or do I apply the update only to the web server running the ISPConfig interface?

Thanks,
Tom

pakogah 27th February 2013 08:43

+1 on this also

till 27th February 2013 09:44

The update has to be applied on all servers. You should start with the master server. The updater will ask if it shll update permissions in the master database, you should have to say "y" on one of the servers, it does not matter which one as all permissions get updated for all servers in this case.

As a sidenote: We will release a bugfix version soon which fixes the bugs found in the last two days, so you might want to wait a few days until you update.

pakogah 27th February 2013 20:08

Quote:

Originally Posted by till (Post 292721)
The update has to be applied on all servers. You should start with the master server. The updater will ask if it shll update permissions in the master database, you should have to say "y" on one of the servers, it does not matter which one as all permissions get updated for all servers in this case.

As a sidenote: We will release a bugfix version soon which fixes the bugs found in the last two days, so you might want to wait a few days until you update.

thanks Till

I followed this how to
http://www.faqforge.com/linux/contro...e-ispconfig-3/

I don't which bugs you mention but I found at least two problem when upgrading to 3.0.5.1

vlogger need perl TimeDate Format.pm to run properly and somehow vlogger can run properly without that perl package befor upgrade

solved at http://www.howtoforge.com/forums/sho...3&postcount=30

and ISPconfig control panel's url caused Internal Server error due to can't find php location. solved by editing /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter

Change path "/usr/lib/cgi-bin/php" to "/usr/bin/php-cgi \"

http://www.howtoforge.com/forums/sho...25&postcount=2

till 27th February 2013 23:34

Quote:

vlogger need perl TimeDate Format.pm to run properly and somehow vlogger can run properly without that perl package befor upgrade
vlogger needed this package in all ispconfig 3 versions, so nothing new in 3.0.5.

Quote:

and ISPconfig control panel's url caused Internal Server error due to can't find php location. solved by editing /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter

Change path "/usr/lib/cgi-bin/php" to "/usr/bin/php-cgi \"

http://www.howtoforge.com/forums/sho...25&postcount=2
Then you did not install the 3.0.5.1 version that we released today.

pakogah 28th February 2013 11:50

yes I installed version 3.0.5.1
On Help tab, I saw "ISPConfig Version: 3.0.5.1"
you can see my first reply to this thread is submitted at 27 feb 2013 the same release date with ISPconfig 3.0.5.1

but nevermind now the panel is working normally,
next I 'll be testing create a site

thank you very much for your hard work and quick response


All times are GMT +2. The time now is 10:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.