HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Admin login failed after upgrading to 3.0.5 (http://www.howtoforge.com/forums/showthread.php?t=60691)

jurrien 26th February 2013 13:23

Admin login failed after upgrading to 3.0.5
 
Hi,

I upgraded ispconfig to version 3.0.5 and I had some problems. I'm running on Centos 5.
First I had to change /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter the exec part to " exec /usr/bin/php-cgi -d magic_quotes_gpc=off

Ok fine I get an admin page again but when I tried to login it rejects my password. Euhm...?

Oke fine I click on Password Lost... I have to fill in a email adres and login. Oke the login is admin but I don't remember the email address. Is there a place in the database where I can look it up? Never filled the e-mail for a account...

What is a way to fix this?

jurrien 26th February 2013 13:49

Also other user also cannot login with the ispconfig contral panel.

No errors in /var/log/httpd/ log files...

till 26th February 2013 14:00

Quote:

First I had to change /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter the exec part to " exec /usr/bin/php-cgi -d magic_quotes_gpc=off
Which path was in the file before you updated it?

Quote:

Oke fine I click on Password Lost... I have to fill in a email adres and login. Oke the login is admin but I don't remember the email address. Is there a place in the database where I can look it up? Never filled the e-mail for a account...
This does not nescessarily mean that the password is wrong, so dont update the admin password. The same error occurs when php is not able to connect to mysql.

Pleasecheck if your are able to login to mysql (e.g. with phpmyadmin) with the login details from file /usr/local/ispconfig/interface/lib/config.inc.php

jurrien 26th February 2013 14:08

Quote:

Originally Posted by till (Post 292608)
Which path was in the file before you updated it?

/usr/lib/cgi-bin/php

Quote:

Originally Posted by till (Post 292608)
This does not nescessarily mean that the password is wrong, so dont update the admin password. The same error occurs when php is not able to connect to mysql.

Pleasecheck if your are able to login to mysql (e.g. with phpmyadmin) with the login details from file /usr/local/ispconfig/interface/lib/config.inc.php

Yes, no problems to login into the database.

Germanius 26th February 2013 14:11

Similar problem here. After upgrading from 3.0.5 RC to stable the loginpage of ISPC loads very slowly. I can not login anymore.
No problem to login via phpmyadmin, it loads very fast.

jurrien 26th February 2013 14:15

Quote:

Originally Posted by Germanius (Post 292614)
Similar problem here. After upgrading from 3.0.5 RC to stable the loginpage of ISPC loads very slowly. I can not login anymore.
No problem to login via phpmyadmin, it loads very fast.

Oke! I thought my webserver was very busy but indeed also my inlog page loads very slowly.

till 26th February 2013 14:16

We found the reason for the first issue with the path, it is a bug in ispconfig versions before 3.0.5 which inserted a wrong path, the problem was not visible till now as the ispconfig interface had a mod_php fall back which has been removed now for security reasons.

The second issue is most likely related to the first one, php-fcgi has a problem to connect to mysql.

Here the steps for a short fix:

Edit the file ispconfig vhost file:

Centos: /etc/httpd/conf/sites-enabled/000-ispconfig.vhost
Debian / Ubuntu: /etc/apache2/sites-enabled/000-ispconfig.vhsot

and change the lines:

Code:

#  <IfModule mod_php5.c>
#    DocumentRoot /usr/local/ispconfig/interface/web/
#    AddType application/x-httpd-php .php
#    <Directory /usr/local/ispconfig/interface/web>
#      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
#      Options FollowSymLinks
#      AllowOverride None
#      Order allow,deny
#      Allow from all
#          php_value magic_quotes_gpc        0
#    </Directory>
#  </IfModule>

to:

Code:

  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
          php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>

Then run:

chmod 660 /usr/local/ispconfig/interface/lib/config.inc.php

and restart apache. Then try to login again.

jurrien 26th February 2013 14:38

I'm sorry but it is still slow and not working and I can't login with any user on the control panel.

Germanius 26th February 2013 15:03

Quote:

Originally Posted by jurrien (Post 292626)
I'm sorry but it is still slow and not working and I can't login with any user on the control panel.

Same here.

falko 26th February 2013 15:29

What's your PHP version?


All times are GMT +2. The time now is 19:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.