HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Difficulties switching to port 587 in Postfix (http://www.howtoforge.com/forums/showthread.php?t=60683)

mroppolo 26th February 2013 02:49

Difficulties switching to port 587 in Postfix
 
Hello all -

My ISP has started blocking port 25 and I am having difficulty adding port 587 to my postfix configuration. I have added the following:

1) TLS settings in /etc/postfix/main.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_tls_security_level = encrypt
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtp_tls_session_cache_database = btree:/var/lib/postfix/smtpd_scache_tls
tls_random_source=dev:/dev/urandom
2) SASL settings in /etc/postfix/main.cf
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = hash:/etc/postfix/saslpasswd
smtp_always_send_ehlo = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
3) relayhost settings in /etc/postfix/main.cf
relayhost = [smtp.comcast.net]:587
4) /etc/postfix/saslpasswd
[smtp.comcast.net]:587 <MyUser>:<MyPasswd>
5) I hashed /etc/postfix/saslpasswd with the following command:
postmap /etc/postfix/saslpasswd
6) I then executed the following commands:
postfix reload
/etc/init.d/postfix restart
7) I opened port 587 on my router

8) I added port 587 to my ISPConfig3 firewall

I still cannot send or receive emails, but I'm seeing this in my mail log:
postfix/smtp[4210]: 341721120004: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=1039, delays=1039/0.04/0.01/0, dsn=4.7.4, status=deferred (TLS is required, but was not offered by host 127.0.0.1[127.0.0.1])
Is anything in configuration incorrect ? Am I missing any steps ?

Thanks !

TiTex 26th February 2013 14:26

you need port 25 also because mail serveres from arround de world will try to send you e-mail to that port not 587

mroppolo 26th February 2013 18:45

Hi Titex (et all) -

I indeed have port 25 open, as well as 587.

I forgot to display the smtpd lines from my master.cf file. I believe they are:
smtp inet n - - - - smtpd
587 inet n - - - - smtpd
submission inet n - - - - smtpd
Please note the 3rd column of "-/n" is "-".

Also, my Mail Queue has 3 messages waiting, with the following error:
(TLS is required, but was not offered by host 127.0.0.1[127.0.0.1])
Nothing coming in or going out ... :(

Thanks !


All times are GMT +2. The time now is 11:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.